iTunes 5 download is corrupt with 1.0.6 on OS X and XP

RESOLVED INVALID

Status

()

Toolkit
Downloads API
--
major
RESOLVED INVALID
12 years ago
9 years ago

People

(Reporter: Matt Watson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

If I download the above URL, I get a corrupted file on both Mac OS X and Windows
XP SP2 when using Firefox 1.0.6.

Specifically, the corruption is zeros from bytes 0x1f0ade9 to 0x1fofde8 --
exactly 20480 bytes.

This seems to be the cause of great amount of complaints from users trying to
download the new iTunes version. See:

http://discussions.info.apple.com/webx?14@602.e3htaL3eR9j.1@.68b8eb3b

It works fine using IE on Windows or Safari on the Mac.

Reproducible: Always

Steps to Reproduce:
1. Dowload the above URL (obtained from http://apple.com/itunes/download)
2. Launch the resulting binary on Windows XP


Actual Results:  
You get a "some files are corrupt" message from the installer

Expected Results:  
Launched and run the iTunes installer.
(Reporter)

Comment 1

12 years ago
That byte range should be:

0x1f0ade9 to 0x1f0fde8

of course.

also, I just tried Firefox 1.0.2 on Mac OS and the download resulted in the
correct file.

Comment 2

12 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050909
Firefox/1.4 ID:2005090906

Changing OS to ALL.

Updated

12 years ago
OS: Windows XP → All
(Reporter)

Comment 3

12 years ago
Sigh.

It turns out that the IE/Safari versions have the same checksum as each other (different from the FF 1.0.6 
version, and no zero corruption), but they still end up with the "some files are corrupted" error from the 
installer.

So, this should just be considered a "download results in different binaries" bug instead...

Comment 4

12 years ago
yes, apple has annonced that there was an issue on there side.
http://discussions.info.apple.com/webx?50@514.g6nSajYjRcg.1@.68b8f026

please try again.

Comment 5

12 years ago
Apple takes the blame for this one...  Resolving INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.