use of brackets/braces inline, style="{...}" often fails vs style="..." to render properly

RESOLVED DUPLICATE of bug 193657

Status

()

Core
CSS Parsing and Computation
--
major
RESOLVED DUPLICATE of bug 193657
13 years ago
13 years ago

People

(Reporter: Licinio Alves, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Often Firefox fails to render style="..." for tags if braces are used, IE
renders it properly with or without the use of braces.

e.g. this first example doesn't apply the syle properly but the second group of
code does, only difference is use of braces in <ul style="{...}">, which is allowed.

<b>Browse by (THERE SHOULD BE NO SPACE BEFORE THE LIST BELOW):</b>
<ul style="{margin-top:0;}">
<li><a href="Q70MCDBServlet?Part_Menu">Part Numbers &amp; Descriptions</a></li>
<li><a href="Q70MCDBServlet?Kit_Menu">Kits</a></li>
<li><a href="Q70MCDBServlet?PartFamily_Menu">Part Family/Part Type</a></li>
</ul>

<b>Browse by (THERE SHOULD BE NO SPACE BEFORE THE LIST BELOW):</b>
<ul style="margin-top:0;">
<li><a href="Q70MCDBServlet?Part_Menu">Part Numbers &amp; Descriptions</a></li>
<li><a href="Q70MCDBServlet?Kit_Menu">Kits</a></li>
<li><a href="Q70MCDBServlet?PartFamily_Menu">Part Family/Part Type</a></li>
</ul>

Reproducible: Always

Steps to Reproduce:
1. see detailed examples above...
2.
3.
Curly brace delimeters should not be used in inline style as per the html spec:
http://www.w3.org/TR/html4/present/styles.html#h-14.2.2

Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Updated

13 years ago
Component: General → Style System (CSS)
Product: Firefox → Core
Version: unspecified → Trunk

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 193657 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.