Closed Bug 307848 Opened 15 years ago Closed 15 years ago

Build error: coreconf/config.mk: No such file or directory

Categories

(NSS :: Build, defect)

3.11
x86
Windows 2000
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: hhf, Assigned: wtc)

References

Details

Attachments

(1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

I download the latest source code from CVS server, and try to build the Firefox.
This is my .mozconfig file when built Firefox:

. $topsrcdir/browser/config/mozconfig

export BUILD_OFFICIAL=1
export MOZILLA_OFFICIAL=1
mk_add_options MOZ_CO_PROJECT=browser
mk_add_options BUILD_OFFICIAL=1
mk_add_options MOZILLA_OFFICIAL=1

ac_add_options --enable-shared
ac_add_options --disable-static

ac_add_options --disable-activex
ac_add_options --disable-activex-scripting

ac_add_options --disable-mailnews
ac_add_options --disable-calendar
ac_add_options --disable-xinerama
ac_add_options --disable-ctl
ac_add_options --disable-mathml
ac_add_options --disable-ldap-experimental

ac_add_options --disable-tests
ac_add_options --disable-gtktest

ac_add_options --enable-debug
ac_add_options --enable-strip
ac_add_options --enable-strip-libs

ac_add_options --disable-toolkit-gtk
ac_add_options --disable-toolkit-xlib
ac_add_options --disable-toolkit-qt
ac_add_options --disable-accessibility
ac_add_options --disable-installer

ac_add_options --disable-optimize


Reproducible: Always

Steps to Reproduce:
1. Start cygwin and change current directory to the Firefox source code root.
2. type make -f client.mk build
3. build some source source always be passed, but failed on building
security\nss\lib\freebl

Actual Results:  
The following is the segment of the output:

lib -NOLOGO -OUT:"d:/firefox/mozilla/mozilla/nss/freebl/freebl.lib" d:\\firefox\
\mozilla\\mozilla\\nss\\freebl\\loader.obj
echo d:/firefox/mozilla/mozilla/nss/freebl/freebl.lib
d:/firefox/mozilla/mozilla/nss/freebl/freebl.lib
nsinstall -m 664 d:/firefox/mozilla/mozilla/nss/freebl/freebl.lib d:/firefox/moz
illa/mozilla/dist/lib
mkdir d:/firefox/mozilla/mozilla/nss/freebl/WIN95_SINGLE_SHLIB
cp /cygdrive/d/firefox/mozilla/mozilla/security/nss/lib/freebl/Makefile d:/firef
ox/mozilla/mozilla/nss/freebl/WIN95_SINGLE_SHLIB
cp /cygdrive/d/firefox/mozilla/mozilla/security/nss/lib/freebl/manifest.mn d:/fi
refox/mozilla/mozilla/nss/freebl/WIN95_SINGLE_SHLIB
cp /cygdrive/d/firefox/mozilla/mozilla/security/nss/lib/freebl/config.mk d:/fire
fox/mozilla/mozilla/nss/freebl/WIN95_SINGLE_SHLIB
cd d:/firefox/mozilla/mozilla/nss/freebl/WIN95_SINGLE_SHLIB && /usr/bin/make -j1
 FREEBL_CHILD_BUILD=1 \
 FREEBL_PARENT=../.. CORE_DEPTH=../../../../.. libs
make[6]: Entering directory `/cygdrive/d/firefox/mozilla/mozilla/nss/freebl/WIN9
5_SINGLE_SHLIB'
Makefile:51: ../../../../../coreconf/config.mk: No such file or directory
Makefile:365: ../../../../../coreconf/rules.mk: No such file or directory


Expected Results:  
Can build Firefox with shared libraries.

When I try to modify the nss\lib\manifest.mn to remove the freebl module. It is
successful util run shlibsign to sign softokn3.dll with error "IO error occurred".
I am almost certain that this has nothing to do with --enable-shared.
Assignee: nobody → wtchang
Component: Build Config → Build
Product: Firefox → NSS
QA Contact: build.config → wtchang
Summary: Cannot build firefox with --enable-shared → Build error: coreconf/config.mk: No such file or directory
I thinkd the freebl's makefile has did something for --enable-shared. The macro
FREEBL_BUILD_SINGLE_SHLIB is for this.
Attached patch Please try this patch (obsolete) — Splinter Review
The problem is that you didn't check out the Firefox source
tree correctly.  You need to follow the instructions in
http://www.mozilla.org/cvs.html.  You should use "cvs checkout"
to check out only one file: mozilla/client.mk.	Then, you need to
use that makefile to check out the rest of the source tree:

    make -f client.mk checkout

The mozilla/client.mk makefile will check out the correct
version of NSS (mozilla/security/nss and mozilla/security/coreconf).
For the Firefox tip, this version of NSS has the CVS tag NSS_CLIENT_TAG.
You are using the tip of NSS.

However, you reported a problem that we will need to fix eventually.
So if you are willing to help, please keep the source tree you
have, and apply this patch.  It's okay if you don't have time to
test this patch.  Thank you.
Attachment #195773 - Attachment is obsolete: true
This bug has been fixed by two patches in bug 303508
(attachment 195819 [details] [diff] [review] and attachment 195950 [details] [diff] [review]).
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Target Milestone: --- → 3.11
Version: unspecified → 3.11
*** Bug 308792 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.