Last Comment Bug 307879 - Nullplugin never stops loading
: Nullplugin never stops loading
Status: RESOLVED FIXED
: fixed1.8, regression
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86 Linux
: P1 normal (vote)
: mozilla1.8beta5
Assigned To: Christian :Biesinger (don't email me, ping me on IRC)
:
:
Mentors:
http://biesi.damowmow.com/object/033....
Depends on:
Blocks: 1156 308038
  Show dependency treegraph
 
Reported: 2005-09-10 06:12 PDT by Christian :Biesinger (don't email me, ping me on IRC)
Modified: 2006-03-12 18:54 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (3.26 KB, patch)
2005-09-10 06:24 PDT, Christian :Biesinger (don't email me, ping me on IRC)
jst: review+
darin.moz: superreview+
asa: approval1.8b5+
Details | Diff | Splinter Review

Description Christian :Biesinger (don't email me, ping me on IRC) 2005-09-10 06:12:42 PDT
Steps to reproduce:
- Load http://biesi.damowmow.com/object/033.html
- observe that throbber doesn't stop, and that statusbar only shows ~50% done

I think that plugins code suspends the channel here and never resumes it...

bug 241592 should have fixed this, but it looks like that patch only changed
windows, not linux (nor mac, for that matter)

seamonkey linux gtk2 trunk, checkout finish: Sa Sep 10 13:12:00 CEST 2005
Comment 1 Christian :Biesinger (don't email me, ping me on IRC) 2005-09-10 06:24:38 PDT
Created attachment 195534 [details] [diff] [review]
patch

turns out that mac doesn't necessarily need any changes (since it just consumes
any number of bytes, so it doesn't have this bug)

with this page, I get three nullplugins on the testcase! that matches all the
other platforms and expected behaviour :-)
Comment 2 Johnny Stenback (:jst, jst@mozilla.com) 2005-09-12 17:40:11 PDT
Comment on attachment 195534 [details] [diff] [review]
patch

r=jst
Comment 3 Darin Fisher 2005-09-14 17:32:32 PDT
Comment on attachment 195534 [details] [diff] [review]
patch

sr=darin
Comment 4 Christian :Biesinger (don't email me, ping me on IRC) 2005-09-15 09:06:45 PDT
Checking in modules/plugin/samples/default/unix/npshell.c;
/cvsroot/mozilla/modules/plugin/samples/default/unix/npshell.c,v  <-- 
npshell.cnew revision: 1.19; previous revision: 1.18
done
Checking in modules/plugin/samples/unixprinting/npshell.c;
/cvsroot/mozilla/modules/plugin/samples/unixprinting/npshell.c,v  <-- 
npshell.cnew revision: 1.3; previous revision: 1.2
done
Comment 5 Christian :Biesinger (don't email me, ping me on IRC) 2005-09-15 09:09:25 PDT
Comment on attachment 195534 [details] [diff] [review]
patch

makes it so that pages with the nullplugin actually finish loading. this does
not affect firefox (which doesn't use the nullplugin), but it improves the
behaviour for seamonkey on linux. low risk: similar code in the windows
nullplugin has worked fine for a long time.
Comment 6 Christian :Biesinger (don't email me, ping me on IRC) 2005-09-16 04:44:35 PDT
fixed on MOZILLA_1_8_BRANCH
Checking in modules/plugin/samples/default/unix/npshell.c;
/cvsroot/mozilla/modules/plugin/samples/default/unix/npshell.c,v  <--  npshell.c
new revision: 1.18.28.1; previous revision: 1.18
done
Checking in modules/plugin/samples/unixprinting/npshell.c;
/cvsroot/mozilla/modules/plugin/samples/unixprinting/npshell.c,v  <--  npshell.c
new revision: 1.2.28.1; previous revision: 1.2
done

Note You need to log in before you can comment on or make changes to this bug.