beneficialcard.co.uk uses bad browser-sniffing, causing spurious errors in Camino (fine in Firefox)

RESOLVED INCOMPLETE

Status

Tech Evangelism Graveyard
English Other
RESOLVED INCOMPLETE
13 years ago
3 years ago

People

(Reporter: Mike Today, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050908 Camino/0.9a2+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050908 Camino/0.9a2+

This problem is also apparent on www.partnershipcard.co.uk. Which seems to use
very similar site construction presumably written by the same software company.
Although I choose the menu option (which is generated by the javascript
expandMenu("smenu01_01"); function, I think) the site believes that I have hit
the back or refresh button (which I have not) and gives this error: "Please do
not use the back or refresh buttons while accessing this site. Relogon to
continue." This is a relatively new problem, I would guess since 0.9. 

I also note that the formatting of the Beneficial home page is completely
different to that under Safari. This is a relatively minor problem, however.

Reproducible: Always

Steps to Reproduce:
1. Login to online banking with a valid account.
2. Select the "Recent Transactions" menu option
3.

Actual Results:  
Apparently logged out with error message: "Please do not use the back or refresh
buttons while accessing this site. Relogon to continue." 

Expected Results:  
Gone to display my recent transactions. Safari 1.3 works fine.
what does it do in firefox?
(Reporter)

Comment 2

13 years ago
Firefox 1.0.6 works fine on both sites. 

I also note that Firefox 1.0.6 is a recognised browser on another on-line
banking site, https://www.nwolb.com, whereas Camino is not recognised. Could
this be a similar problem (I have tried modifying the UserAgent string via
prefs.js without success). 
please test against 1.5beta. firefox 1.0.x is equivalent to camino 0.8
I get a server error when trying to access the URL listed in the URL field
above, but I assume it's behind the password-protected area.

(In reply to comment #2)

> I also note that Firefox 1.0.6 is a recognised browser on another on-line
> banking site, https://www.nwolb.com, whereas Camino is not recognised. Could
> this be a similar problem (I have tried modifying the UserAgent string via
> prefs.js without success). 

Completely off-topic for this bug; nwolb.com is browser sniffing only for
browsers that they know about (Fx 1.5beta is also denied entry), and most
sniffers don't have an entry for Camino (see rants about why sniffing is bad).  

Using Fx 1.0.6's user-agent string should get you the login page; you need to
contact the bank and/or file a bug against the Tech Evangelism component in
Bugzilla, as Camino supports the same security features/functions as the
equivalent version of Firefox or Mozilla.
(Reporter)

Comment 5

13 years ago
Firefox 1.5 Beta 1 works fine on both sites.

I have also changed the URL. Use the new one and choose Login on the left-hand
side. Then follow step 2 above.
Mike (Today), without access to the site it's hard to know exactly what's causing it. Saving a copy of the page on which this is happening would be helpful (choose HTML Complete from the save dialog). Additionally, if you're okay with one of us triagers logging in as you to try this, that could help a lot as well. Is there any more info you can give for this?
(Reporter)

Comment 7

12 years ago
I would not be comfortable allowing one of you triagers logging into my account. Equally a saved web page does have some confidential information in it. As a way forward is there any way I can get access to the nightly builds (binaries) for the past several months so that I can attempt to identify at what point I began to get this error? 

Comment 8

12 years ago
Mike Today, here is the link to all the builds from the last year and a half ;) 

ftp://ftp.mozilla.org/pub/mozilla.org/camino/nightly/

Note that most recently we make two build (branch and trunk) and you should only look in the folders that have -1.0 at the end.
Mike Today: is this still happening?  If so, have you been able to track down in which build it broke?
Whiteboard: [CLOSEME - 12/18]
Since we have not heard back from the reporter, closing this bug as WFM. Please reopen if the problem persists.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Whiteboard: [CLOSEME - 12/18]

Comment 11

11 years ago
Reopening and kicking to TE. Mike, is this still a problem with recent Camino nightlies?
Status: RESOLVED → UNCONFIRMED
Component: General → English Other
Product: Camino → Tech Evangelism
Resolution: WORKSFORME → ---
Summary: Get message "Please do not use the back or refresh buttons while accessing this site. Relogon to continue." when selecting menu option. I have not used the buttons mentioned. → beneficialcard.co.uk uses bad browser-sniffing, causing spurious errors in Camino (fine in Firefox)

Updated

11 years ago
Assignee: mikepinkerton → english-other
QA Contact: english-other

Comment 12

10 years ago
I'm going to resolve this INCOMPLETE since we never did figure out whether it was a problem or not.

If someone wants to file a new bug detailing new steps to reproduce this problem, please feel free to do so.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago10 years ago
Resolution: --- → INCOMPLETE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.