clicking flash logo on www.entertaindom.com crashes browser

VERIFIED WORKSFORME

Status

()

P3
critical
VERIFIED WORKSFORME
19 years ago
19 years ago

People

(Reporter: jruderman, Assigned: serhunt)

Tracking

({crash})

Trunk
x86
Windows 98
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
There might be something wrong with my computer, but www.entertaindom.com 
crashes both mozilla and internet explorer 5 on my computer.  I have tried 
rebooting.  Builds 2000 030408 and 2000 030516.

If this helps anyone find the bug in mozilla, IE gets locked into a repeated 
crash where clicking "close" on the illegal operation brings another illegal 
operation back up immediately, and ctrl-alt-del doesn't work.

MOZILLA caused an invalid page fault in
module <unknown> at 0000:00000009.
Registers:
EAX=00000000 CS=015f EIP=00000009 EFLGS=00250202
EBX=00000000 SS=0167 ESP=0068af50 EBP=0068af90
ECX=54794600 DS=0167 ESI=0293cb40 FS=4b5f
EDX=10034de9 ES=0167 EDI=00000000 GS=57d6
Bytes at CS:EIP:
00 4f 14 65 04 70 00 65 04 70 00 54 ff 00 f0 79 
Stack dump:
00000167 029396c0 0293cb50 00000001 02939bf0 00000030 00000000 00000000 
02939cb0 029396f0 00000000 029396c0 00000001 00000008 02939c00 02939bd0

Comment 1

19 years ago
I don't crash here in 3/6 nightly under NT.  THe page is a re-direct to a Get
Flash page.  Reporter, could you check to see if you have any other flash
related problems.  Maybe go to macromedia's website and check some flash examples.

Comment 2

19 years ago
Confirmed this with Win95 build 03/05 (I have no IE though). Visiting the given 
site, crashes Mozilla after starting to load 
http://www.entertaindom.com/pages/index.jsp

Crash data:

MOZILLA verursachte einen Fehler durch eine ungültige Seite
in Modul <Unbekannt> bei 0000:0000000b.
Register:
EAX=00000000 CS=0137 EIP=0000000b EFLGS=00250297
EBX=00000000 SS=013f ESP=0068af54 EBP=0068af94
ECX=00467554 DS=013f ESI=008e4310 FS=3e0f
EDX=10034dd2 ES=013f EDI=00000000 GS=3e16
Bytes bei CS:EIP:
0f 65 04 70 00 65 04 70 00 54 ff 00 f0 78 88 00 
Stapelwerte:
0000013f 008e4370 008e4320 00000001 008e3ae0 ffffffb0 00000000 00000000 008e3d20 
008e4340 00000000 008e4370 00000001 00000008 008e3a70 008e3ac0 

I alread could view Flash4 content before.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

19 years ago
This worksforme at http://www.entertaindom.com/ which re-directs to
http://www.entertaindom.com/pages/entry/download_flash.jsp?show=default (the Get
Flash Now page)

I also load without fail at http://www.entertaindom.com/pages/index.jsp

Tested under winNT with 030608 build.

Comment 4

19 years ago
Finally found the original bug: 
Viewing Shockrave JSP page leads to infinite refresh loop, crash

*** This bug has been marked as a duplicate of 15807 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 5

19 years ago
not a dupe
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

19 years ago
Severity: major → critical
Keywords: crash

Comment 6

19 years ago
Still not crashing here on 98 or NT with 3/7 build.  I'll check it again later
today with a 3/9 build.

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → WORKSFORME

Comment 7

19 years ago
I tried with build 03/08 and could display it without problems. So it got 
somehow solved. Marking WORKSFORME. Reporter if you see the crash with a newer 
build, reopen it.
(Reporter)

Comment 8

19 years ago
I now get this only after clicking the flash logo in the upper left corner of 
http://www.entertaindom.com .  Clicking on the flash applet (?) goes to 
http://www.entertaindom.com/pages/index.jsp , which the site sometimes 
redirects to and sometimes doesn't redirect to (??).  The crash does not occur 
when I go to http://www.entertaindom.com/pages/index.jsp directly.

Reopening, and replacing summary "www.entertaindom.com crashes both moz and ie" 
with "clicking flash logo on www.entertaindom.com crashes browser".
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: www.entertaindom.com crashes both moz and ie → clicking flash logo on www.entertaindom.com crashes browser

Comment 9

19 years ago
davidr8@home.com, what is the build ID that you were last able to reproduce this
with?
(Reporter)

Comment 10

19 years ago
2000 030918.  Currently getting it about half the time, and often I have to go 
to the site twice (one way would be to go to entertaindom.com and then type 
www.entertaindom.com into the location bar).

Comment 11

19 years ago
Again confirmed with Win95 build 03/08. 
Page showsw up, Viewing flash content right in the middle of the screen (win a 
car or something) works,
while clicking on "Entertaindom.com" in the upper left edge of the window gives 
a crash.
Unfortunately I have no chance of getting a stack trace in Windows (is there a 
tool to get one?), so I can't see if this is the same Flash crasher as bug 27558
One more datapoint.  I don't have flash set up and I can't reproduce this 
crash.  tested on 3/9 as well under NT

Comment 13

19 years ago
*** Bug 31368 has been marked as a duplicate of this bug. ***

Comment 14

19 years ago
Looks like a plugin problem.  Changing component.
Assignee: cbegle → av
Status: REOPENED → NEW
Component: Browser-General → Plug-ins
QA Contact: asadotzler → shrir

Comment 15

19 years ago
I don;t see this problem on today's windows build 2000031314. The page loads 
fine and does not crash at all. Marking worksforme.
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → WORKSFORME

Comment 16

19 years ago
True, 03/13 doesn't crash anymore. Marking VERIFIED
Status: RESOLVED → VERIFIED
(Reporter)

Comment 17

19 years ago
I'm still getting this. New steps to reproduce:
1. Type www.entertaindom.com into location bar. you'll end up at 
http://www.entertaindom.com/pages/index.jsp.
2. Type entertaindom.com into location bar. The browser will start to load 
http://entertaindom.com/pages/index.jsp and crash.

Switching (1) and (2) does produce a crash, but repeating either by itself 
doesn't.  Including the /pages/index.jsp part in either or both steps doesn't 
seem to affect the crash much.

I'm now only experiencing this problem with mozilla, not with internet explorer.

I have version 4,0,13,0 of C:\WINDOWS\SYSTEM\MACROMED\FLASH\swflash.ocx and 
also a file with size 1511 bytes called 
C:\Program Files\Netscape\Communicator\Program\Plugins\ShockwaveFlash.class.

Questions:
- Is this happening in a third party application (a plugin) or in mozilla?
- Is it mozilla's fault?
- Why does it only happen if you switch sites?
- Can someone experiencing this crash get a NEW version of shockwave flash and 
report whether it still happens?

Reopening bug.
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---

Comment 18

19 years ago
Ok.. I agree !! If I try to open the same webpage in another window (with the 
first window open), then I definitely get a crash. This webpage loads fine on a 
single page.

Stack trace :

Trigger Type:  Program Crash
Trigger Reason:  Access violation
Thread ID: 
210
Call Stack:    (Signature = 0x00000000 633fd4d0)
     0x00000000  
     0x0cf6d140  
     gkplugin.dll + 0x4f40 (0x60a04f40)  
     gkplugin.dll + 0x2f0f (0x60a02f0f)  
     gkplugin.dll + 0x2938 (0x60a02938)  
     gkhtml.dll + 0x1f52a (0x6018f52a)  
     gkhtml.dll + 0x1f1ea (0x6018f1ea)  
     gkhtml.dll + 0x33697 (0x601a3697)  
     gkhtml.dll + 0x24562 (0x60194562)  
     gkhtml.dll + 0x24374 (0x60194374)  
     gkhtml.dll + 0x2422d (0x6019422d)  
     gkhtml.dll + 0x33697 (0x601a3697)  
     gkhtml.dll + 0x3b8f2 (0x601ab8f2)  
     gkhtml.dll + 0x3b793 (0x601ab793)  
     gkhtml.dll + 0x3b684 (0x601ab684)  
     gkhtml.dll + 0x3b56d (0x601ab56d)  
     gkhtml.dll + 0x3a954 (0x601aa954)  
     gkhtml.dll + 0x3a5ad (0x601aa5ad)  
     gkhtml.dll + 0x39aa1 (0x601a9aa1)  
     gkhtml.dll + 0x2ee71 (0x6019ee71)  
     gkhtml.dll + 0x912a6 (0x602012a6)  
     gkhtml.dll + 0x2ee71 (0x6019ee71)  
     gkhtml.dll + 0x90256 (0x60200256)  
     gkhtml.dll + 0x90095 (0x60200095)  
     gkhtml.dll + 0x90435 (0x60200435)  
     gkhtml.dll + 0x2ee71 (0x6019ee71)  
     gkhtml.dll + 0x8de7d (0x601fde7d)  
     gkhtml.dll + 0x8d871 (0x601fd871)  
     gkhtml.dll + 0x8d604 (0x601fd604)  
     gkhtml.dll + 0x2ee71 (0x6019ee71)  
     gkhtml.dll + 0x89ff7 (0x601f9ff7)  
     gkhtml.dll + 0x89d86 (0x601f9d86)  
     gkhtml.dll + 0x88ab0 (0x601f8ab0)  
     gkhtml.dll + 0x2ee71 (0x6019ee71)  
     gkhtml.dll + 0x868a8 (0x601f68a8)  
     gkhtml.dll + 0x863fa (0x601f63fa)  
     gkhtml.dll + 0x863d9 (0x601f63d9)  
     gkhtml.dll + 0x86348 (0x601f6348)  
     gkhtml.dll + 0x86d9e (0x601f6d9e)  
     gkhtml.dll + 0x3efb1 (0x601aefb1)  
     gkhtml.dll + 0x3b226 (0x601ab226)  
     gkhtml.dll + 0x3a805 (0x601aa805)  
     gkhtml.dll + 0x3a5ad (0x601aa5ad)  
     gkhtml.dll + 0x39aa1 (0x601a9aa1)  
     gkhtml.dll + 0x2ee71 (0x6019ee71)  
     gkhtml.dll + 0x912a6 (0x602012a6)  
     gkhtml.dll + 0x2ee71 (0x6019ee71)  
     gkhtml.dll + 0x90256 (0x60200256)  
     gkhtml.dll + 0x90095 (0x60200095)  
     gkhtml.dll + 0x90435 (0x60200435)  
     gkhtml.dll + 0x2ee71 (0x6019ee71)  
     gkhtml.dll + 0x8de7d (0x601fde7d)  
     gkhtml.dll + 0x8d871 (0x601fd871)  
     gkhtml.dll + 0x8d604 (0x601fd604)  
     gkhtml.dll + 0x2ee71 (0x6019ee71)  
     gkhtml.dll + 0x89ff7 (0x601f9ff7)  
     gkhtml.dll + 0x89d86 (0x601f9d86)  
     gkhtml.dll + 0x88ab0 (0x601f8ab0)  
     gkhtml.dll + 0x2ee71 (0x6019ee71)  
     gkhtml.dll + 0x868a8 (0x601f68a8)  
     gkhtml.dll + 0x863fa (0x601f63fa)  
     gkhtml.dll + 0x863d9 (0x601f63d9)  
     gkhtml.dll + 0x86348 (0x601f6348)  
     gkhtml.dll + 0x86d9e (0x601f6d9e)  
(Reporter)

Comment 19

19 years ago
Is this a "compatibilty" problem with the flash plugin?  If so, we should add 
the "flash" keyword.
(Assignee)

Comment 20

19 years ago
I do not see the crash. Tried to do everything described in the report including 
new window. Please note that having some plugins may cause crash on this page, 
e.g. nplips.dll 

Shrirang, if you don't see the problem any more plaese confirm.
Status: REOPENED → ASSIGNED
Target Milestone: --- → M16

Comment 21

19 years ago
not seen anymore. marking wfm.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → WORKSFORME

Comment 22

19 years ago
verified (2000071808)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.