toolbar search does not recognize change of search engine

RESOLVED WORKSFORME

Status

()

Firefox
Search
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: doug edmunds, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

changing selected search engine has no 
effect after something typed in search box.

must open a new browser to use other
search engines

Reproducible: Always

Steps to Reproduce:
1.added search box to navigation toolbar (has google, yahoo, etc,, ends with
"add engines"
2. type something in the box, click go. If on Google, brings up search results.
Change
3. change to yahoo, press go 
4. nothing happens.
5. have to open a new browser (not just tab) to activate a different search
engine.


Actual Results:  
nothing happens, stays in google search engine or whichever was first

Expected Results:  
should have done the search using the other selected search engine
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050910
Firefox/1.4 ID:2005091004

WFM

Comment 2

12 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 (No
IDN) Firefox/1.4

Comment 3

12 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060115 Firefox/1.6a1

It would seem that the green Go button only causes the browser to go to the address in the location bar. It does not seem to activate Search bar. It looks like it might have been a conscious design choice.

WFM.
Search indeed didn't have any "go" to click in 1.4, but does now, and it does work the way you wanted.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Component: Toolbars → Search
QA Contact: toolbars → search
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.