Font prefs should not list Adobe fonts

VERIFIED FIXED in M16

Status

()

P3
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: pierre, Assigned: ftang)

Tracking

({platform-parity})

Trunk
PowerPC
Mac System 8.5
platform-parity
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-], URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
On the Mac, when you install the PDFViewer plugin, Mozilla displays the Adobe 
fonts in the font prefs:
    %MAdobeSanMM_1450 50 10
    %MAdobeSanMM_1450 1450 10
    %MAdobeSanMM_50 50 10
    %MAdobeSanMM_50 1450 10
    etc...

These fonts should not be displayed. None of the other Mac applications do (at 
least SimpleText or ClarisWorks).

I'm going to attach a binhex archive that contains some of these fonts. To 
reproduce the bug:
- decompress the archive
- install the font suitcase in the Fonts folder inside the System Folder
- launch Mozilla
- open the Fonts prefs panel
==> the popup menus should not display the fonts starting with a '%' characters.

Assigned to ftang per discussion with erik.
(Reporter)

Comment 1

19 years ago
Created attachment 6200 [details]
Font suitcase (Adobe Sans MM.sit.hqx)
(Assignee)

Comment 2

19 years ago
1. What does it mean to the user if we still display these fonts ? 
2. If we REALLY want to fix it, we can use the method stated in the "Handy Hint 
for Lists of Font Names" ection of Technical Note TE04 "Font Names" 
http://developer.apple.com/technotes/te/te_04.html to replace the current 
implementation. This mean we do need to crete and dispose an menu.
Status: NEW → ASSIGNED
Target Milestone: M18
(Reporter)

Comment 3

19 years ago
1. It makes the font prefs really confusing because you see a dozen of really 
weird font names that you cannot anywhere else. Another problem is that, since 
they're on top of the list, they tend to be selected as default font when what we 
have defined to be the default font doesn't exist on that particular end-user 
machine.
2. We REALLY want to fix it and the TechNote (thanks for finding it!) shows that 
it should be REALLY easy to do. Marked beta1.
Keywords: beta1

Comment 4

19 years ago
PDT-
Whiteboard: [PDT-]
(Assignee)

Comment 5

19 years ago
Have a fix. ready to check in . move it to M16
Target Milestone: M18 → M16
(Assignee)

Comment 6

19 years ago
Ignore font name start with "." and "%" since they are private system font. 
Fixed check in.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
looks good! verif on mac commecial, 2000.05.09.08.
Status: RESOLVED → VERIFIED
Keywords: beta1 → pp
You need to log in before you can comment on or make changes to this bug.