crashes all *zilla variants when xorg composite enabled and bpp <24

RESOLVED DUPLICATE of bug 304370

Status

()

--
trivial
RESOLVED DUPLICATE of bug 304370
13 years ago
13 years ago

People

(Reporter: jimsantelmo, Unassigned)

Tracking

1.5.0.x Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
Using the 'via' xorg driver currently in Ubuntu Breezy,
both current seamonkey and nearly current firefox fail on the
guardian site, with the .xsession-errors message below.
This does not happen with mozilla-1.7.11, nor with any
of them using the VESA driver. Probably the via driver
is enabling some acceleration or rendering option which
the current rendering engine is trying to use via gtk2
without success.

  The via driver is quite probably ultimately at fault
in some way, but given that only current gecko and
not the version in 1.7.11 is affected, I thought it
worth noting.

.xsession-errors:

 The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 102 error_code 8 request_code 145 minor_code 3)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
~[2]#
(Reporter)

Comment 1

13 years ago
run in gdb with --sync. The seamonkey bt is about the same to #3, then
quite different, no ns* calls.

(gdb) bt
#0  0xb7498576 in exit () from /lib/tls/i686/cmov/libc.so.6
#1  0xb7aa5e78 in _gdk_windowing_exit () from /usr/lib/libgdk-x11-2.0.so.0
#2  0xb78a2eec in _XError () from /usr/lib/libX11.so.6
#3  0xb78a34c1 in _XReply () from /usr/lib/libX11.so.6
#4  0xb788a46b in XInternAtom () from /usr/lib/libX11.so.6
#5  0x0874f8a9 in nsBaseHashtableET<nsStringHashKey, nsCOMPtr<nsIVariant>
>::nsBaseHashtableET ()
#6  0xb769209e in XtDispatchEventToWidget () from /usr/lib/libXt.so.6
#7  0xb769267c in _XtOnGrabList () from /usr/lib/libXt.so.6
#8  0xb769298a in XtDispatchEvent () from /usr/lib/libXt.so.6
#9  0xb769d978 in XtAppProcessEvent () from /usr/lib/libXt.so.6
#10 0x0874ef32 in nsBaseHashtableET<nsStringHashKey, nsCOMPtr<nsIVariant>
>::nsBaseHashtableET ()
#11 0xb794d48e in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#12 0xb7950496 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#13 0xb7950783 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#14 0xb7bf8606 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#15 0x081ebb24 in XmlInitUnknownEncodingNS ()
#16 0x0862e1ae in nsXPTCVariant::Init ()
#17 0x0807a848 in ?? ()
#18 0x08a838d0 in ?? ()
#19 0xb7598900 in __malloc_initialize_hook () from /lib/tls/i686/cmov/libc.so.6
#20 0x00000000 in ?? ()
(Reporter)

Comment 2

13 years ago
 I've seen some crashes with 1.7.11. Have bumped severity down to 'minor'.
Fairly certain this is an xorg-driver-via problem, and have filed a
report in Ubuntu bugzilla on it:

https://bugzilla.ubuntu.com/show_bug.cgi?id=15336
Severity: normal → minor
(Reporter)

Comment 3

13 years ago
  Further experimentation shows that this bug is related to using
DefaultDepth of 16 (haven't tried 8, but 24 and 32 are fine). Thus there is a
reliable browser-crash reproducible currently with 
http://tmobile.com
using all three Gecko-based browser variants I have, but I have no idea
at this point if it is a Gecko bug, an X bug, or involves something else.
I just know it can be switched on and off by changing DefaultDepth.
  It does not at present appear to necessarily involve the Xorg Via
chipset driver, but first appeared coincidentally with my switching
to that from vesa.
  Since I'm running bleeding-edge Ubuntu, I still think it is probably
rooted there, but may be triggering a little-used error-path
in Gecko that doesn't quite work well.
(Reporter)

Comment 4

13 years ago
 I have determined thru experimentation that this bug only triggers
when the Xorg 'composite' extension is enabled. The Ubuntu people
marked the Ubuntu bug I filed as a duplicate of the following
bug dealing with the 'composite' extension:

http://bugzilla.ubuntu.com/show_bug.cgi?id=7406

  As I suspected, this turns out to affect other things than
*zilla. I'll leave it unclosed for now in case someone else runs into
it and searches bugzilla.
Severity: minor → trivial
Summary: crashes both firefox-1.5b1 and seamonkey current trunk when using xorg via driver → crashes all *zilla variants when xorg composite enabled and bpp <24

Comment 5

13 years ago

*** This bug has been marked as a duplicate of 304370 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.