Clicking on expander (chevron) in bookmarks toolbar briefly shows (flashes) all the items in the toolbar

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
--
minor
RESOLVED WONTFIX
12 years ago
9 years ago

People

(Reporter: Michael Stather, Unassigned)

Tracking

1.5.0.x Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050910 Firefox/1.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050910 Firefox/1.4

When clicking on the ">>" expander of the bookmarks toolbar, the menu with the
remaining items pops up an the button disappears (not the caption but the button
is rendered "flat"). But if you move the mouse a little bit it appears again. I
think the button shoudn´t be rendered "flat" on clicking but like every other
button.

Reproducible: Always
i guess this is the result of Bug 203556 and the expander is seen as a "folder"
for the remaining bookmarks

couldn't find a dupe

Comment 2

12 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20050910 Firefox/1.6a1
ID:2005091022

I'm seeing this too. 
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Bookmark expander rendered wrong on clicking → Clicking on expander (sprite) in bookmarks toolbar briefly shows (flashes) all the items in the toolbar
Version: unspecified → Trunk

Comment 3

12 years ago
*** Bug 324938 has been marked as a duplicate of this bug. ***

Comment 4

12 years ago
Mac OS X as well.
OS: Linux → All
Hardware: PC → All

Comment 5

12 years ago
For OS X, please ignore the bug description, which doesn't seem to address the bug summary, and instead describes a vanishing behaviour of the chevron used to bring up the overflow menu. The chevron behaves perfectly normally in Mac OS X.

The only issue is the brief appearance of the wrong items in the Boomarks Toolbar overflow menu, when the window is first loaded. It only does this the first time you access it in a new window.

Comment 6

12 years ago
Further info: the regression occurred between the 20040809-09 and 20040810-15 Firefox trunk builds. It was also present in SeaMonkey by 20040811, but I can't pin down an earlier date as there were no Mac builds at that time. Anyway, it seems to have cropped up way too late to be the result of fixes for bug 203556.

It didn't appear in the 0.9 or 1.0.x branches at all. So the first appearance in an official release would be 1.5.

Maybe more fallout from the fix for bug 230170? A number of things broke at that time.
Does the toolbar use any overflow styles?

Comment 8

12 years ago
Yes, the <stack> element that it's wrapped in uses "overflow: hidden;".

http://lxr.mozilla.org/mozilla/source/browser/base/content/browser.xul#272
Severity: normal → minor
Summary: Clicking on expander (sprite) in bookmarks toolbar briefly shows (flashes) all the items in the toolbar → Clicking on expander (chevron) in bookmarks toolbar briefly shows (flashes) all the items in the toolbar
Does using "overflow: -moz-hidden-unscrollable" instead help at all?
Though actually.... probably not.  This is likely dependent on bug 279703
Depends on: 279703

Comment 11

12 years ago
*** Bug 331297 has been marked as a duplicate of this bug. ***

Comment 12

12 years ago
Removing 324938 as a dupe of this bug, and making it a dupe of bug 331297 instead. Looking at the activity history for this bug, it was supposed to be about some graphics issue where the chevron disappears, and not what the summary has later been changed to. I won't touch it, but suggest that it be put back the way it was (and possibly resolved as WORKSFORME if the original problem can't be reproduced... I've certainly never seen it). Anyone interested in the resizing overflow menu bug can go to bug 331297, which is clean and new.
No longer depends on: 279703

Updated

9 years ago
Version: Trunk → 1.5.0.x Branch
not going to take further fixes on 2.x, feel free to reopen if you can reproduce on 3.x or current trunk
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.