Polish keyboard does not work when language set to English with Firefox & Thunderbird

RESOLVED WONTFIX

Status

()

--
critical
RESOLVED WONTFIX
13 years ago
9 years ago

People

(Reporter: piskozub, Unassigned)

Tracking

Trunk
x86
Windows ME
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
When trying to use Polish national characters (they are types as
RightAlt+[letter]) I just type the latin [letter]. For example typing ąęśćółńżź
in Thunderbird 1.5 beta 1 would result in aescolzzn (especially the final two
are interested as they ar typed as respectively RightAlt-z and RightAlt-x [in
case the Polish letters above are impossible to read, I'll describe the two as
"z with a dot" and "zet with a dash"].

I tested this bug using Windows ME.
(Reporter)

Comment 1

13 years ago
Correction:

as the final two I meant "ż" and "ź" which both look as "z" in T-bird 1.5b1 even
as RightAlt-z and RightAlt-x are used to render them.
(Reporter)

Updated

13 years ago
Flags: blocking1.8b5?

Comment 2

13 years ago
Is this a regression? If so, when did it last work and what change broke it?
(Reporter)

Comment 3

13 years ago
I changed the summary adding "when language set to English" (just as reminder:
we're talking Windows here).

This is simply wrong. My language setting should not affect my keyboard setting. 

Is it regression? Dunno. That is, I'm sure it's one as T-bird 1.06 WFM. But I
have no idea whatsoever when it happened as I never before tested any T-bird
builds based on Gecko 1.8...
Summary: Polish keyboard does not work with Thunderbird 1.5 beta1 → Polish keyboard does not work when language set to English with Thunderbird 1.5 beta1

Comment 4

13 years ago
This could be fixed by bug 287179 which correctly handles international keyboard
layouts that use Ctrl+Alt (=Right Alt) key combinations. This most likely was
broken by bug 217560 (widget/src/windows/nsWindow.cpp v3.506) and later
partially fixed by bug 285161. 

Comment 5

13 years ago
This should really be a core gecko bug right? Thunderbird doesn't interact
directly with polish keyboards per say. Maybe this should be a Core/Widget bug.

This would have to effect Firefox too right?
(Reporter)

Comment 6

13 years ago
Since when Firefox has a message compose window? 

It may affect Seamonkey but my last CVS build (20050909) wasn't able to open the
compose window at all. I had no time last week to make a new one. I'll report
back wnen I do.

Comment 7

13 years ago
since: keyboard input is used to type characters into firefox such as the url
bar, bookmark manager and other places :)
(Reporter)

Comment 8

13 years ago
You're right. I actually use Firefox 1.5 beta 1 and I did not notice this
problem as I never use Polish symbols in either the URL bar or bookmarks manager.

But, yes all the input fields are screwed in this same way. Feel free to change
the component to the right one (I do not want to guess wrong after only 4 hours
of sleep).
(Reporter)

Comment 9

13 years ago
Moving to Core/Widget (I finally grokked comment #7 fully after drinking some
coffee), changing version numbers to the trunk ones.
Component: Message Compose Window → Widget
Product: Thunderbird → Core
Version: 1.5 → Trunk
(Reporter)

Updated

13 years ago
Summary: Polish keyboard does not work when language set to English with Thunderbird 1.5 beta1 → Polish keyboard does not work when language set to English with Firefox & Thunderbird 1.5 beta1
(Reporter)

Comment 10

13 years ago
I checked Seamonkey alpha 1. The result was unexpected. The compose windw worked
for me but the URL bar had the problem described in this bug.

Comment 11

13 years ago
Clearing blocking flag - making bug 287179 blocking since it looks to fix the
core problem.
Flags: blocking1.8b5?
(Reporter)

Comment 12

12 years ago
Nothing changed with Firefox 2.0. I delete the version number from bug summary.

Are there any plans concerning Win_9x? Will there be a mass retiring or are there any chances some will be fixed (at least in the trees which support Win_9x)?
Summary: Polish keyboard does not work when language set to English with Firefox & Thunderbird 1.5 beta1 → Polish keyboard does not work when language set to English with Firefox & Thunderbird
Assignee: mscott → nobody
(Reporter)

Comment 13

9 years ago
Marking as WONTFIX as both products have been discontinued for the platform listed.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.