Use official Answers.com search plugin

RESOLVED DUPLICATE of bug 309379

Status

()

Firefox
Search
--
enhancement
RESOLVED DUPLICATE of bug 309379
13 years ago
13 years ago

People

(Reporter: Matt Nordhoff (aka Peng on IRC & forums), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050911 Firefox/1.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050911 Firefox/1.4

The Dictionary.com search plugin has recently been replaced with an Answers.com
search plugin Ben Goodger wrote (bug 289362), but I've just noticed there's an
official search plugin written by Answers.com:

http://www.answers.com/main/firefox_plugins.jsp
http://download1.answers.com/pub/moztoolbar/answers.src
http://download1.answers.com/pub/moztoolbar/answers.png

I've also just noticed that there is yet another one on Mycroft, written by Roy
Chang:

http://mycroft.mozdev.org/download.html?name=Answers.com&submitform=Find+search+plugins
http://mycroft.mozdev.org/plugins/answers.src
http://mycroft.mozdev.org/plugins/answers.png

Why not use either of them?

They also don't require the changes that "were required to the Internet Search
Service to support answer's query format", and have a correct PNG image (bug
306075).

Reproducible: Always

Steps to Reproduce:
While that would have been reasonable before, now we have the changes. I
wouldn't be surprised if the answers.com folks wanted a big long URL full of
tracking vars (thus cc:rebron, since I think that's his department), but for our
purposes Ben's is better:

Ben's: http://www.answers.com/mozilla
Official: http://www.answers.com/main/ntquery?s=mozilla&method=2&gwp=13
Google:
http://www.google.com/search?hs=xFB&hl=en&lr=&safe=off&c2coff=1&client=firefox-a&rls=org.mozilla%3Aen-US%3Aofficial&q=%22client%3Dfirefox%22&btnG=Search

Which would you rather paste into an email or a blog post? (And the number of
times I've seen &client=firefox-a links in blog posts say those tracking URLs
are pretty useless.)
The Google URL is definitely terribly long (is someone considering taking some
of the stuff out?), but neither Answers.com URL is too long, and I would
consider using the official one just because it is the official one.
Forward-duping to the official bug to officially use the official URL.

*** This bug has been marked as a duplicate of 309379 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.