Overlaying config.xul doesn't overlay about:config

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
13 years ago
9 years ago

People

(Reporter: Jos Vermeulen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050909 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050909 Firefox/1.4

When you overlay chrome://global/content/config.xul in chrome.manifest, the
changes won't apply to "about:config". When you load the chrome-URL directly,
they will.

To test this, you can use this extension: http://ilpolipo.free.fr/fx/classicmenus/.
It will overlay config.xul.

Reproducible: Always

Steps to Reproduce:
1. Create an extension containing a chrome.manifest with "overlay
chrome://global/content/config.xul chrome://classicmenus/content/overlay.xul"
2. Install it
3. Type "about:config". See the overlay not applying.
4. Type "chrome://global/content/config.xul". See the overlay applying.
5. Type "about:config". See the overlay applying.



Expected Results:  
See the overlay applying the first time (step 3).

Comment 1

13 years ago
This is by design: overlays are applied according to the originalURI, not the
actual channel URI.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
Duplicate of this bug: 498099
You need to log in before you can comment on or make changes to this bug.