detaching forwarded mail duplicates the attachment

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: M.J.G., Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: version 1.5 Beta 1 (20050908)

When trying to detach an e-mail which was "forwarded as attachment", TB makes
two attachments with the same name (the subject of the attached message) out of
the one attached message. Double clicking on the first one feeds the detached
message into the default app for text/ascii instead of showing it in a mail
window; double clicking on the second one does open a mail window, but it is empty

Reproducible: Always

Steps to Reproduce:
1. forward an e-mail as attachment
2 [review]. detach the attached e-mail
3. 

Actual Results:  
2 "detachments" are produced
one points to the detached e-mail with type text/ascii
the second points to an empty message

Expected Results:  
produce one "detachment" with type rfc-xyz/message

This is with IMAP.
Deleting an attached message works.
The attached message is a simple text message.

Updated

13 years ago
Version: unspecified → 1.5

Comment 1

13 years ago
worksforme,
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b5) Gecko/20050924 Thunderbird/1.4
ID:2005092407
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> worksforme,
> Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b5) Gecko/20050924 Thunderbird/1.4
> ID:2005092407

Please be more specific about what you tested. Pop or IMAP? What is the type of
the message? Also note that you seem to be using a nightly, not a beta release.

Michael

Comment 3

13 years ago
I tested on IMAP. Forwarded a normal plain text email as attachment, then
detached the attachment when the mail arrived. No problems found, only one
"detachment" created.

Yes, I use a nigtly branch build. Those will eventually become the final 1.5
version so you might want to test if you still get the problem.
(Reporter)

Comment 4

13 years ago
Retested with 20050926 nightly from the moz1.8 branch of TB on linux with an
IMAP account. Now, TB correctly produces one single "detachment".

The second issue mentioned in this bug still remains: double clicking on the
detachment in the attachment shows the choices for a text file, not for an eml
file. TB opens the detachment as a raw text. On the other hand, opening the
detachment via File->Open Saved Message displays it correctly in a message
window. Should I file a separate bug for this?

Comment 5

13 years ago
opening of eml attachments is covered in another bug, I believe.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

13 years ago
(In reply to comment #5)
> opening of eml attachments is covered in another bug, I believe.

Well, this bug (its second half, that is) is about opening detached attachments
whose type is "message/rfc822". I couldn't find any bug on this.

Comment 7

13 years ago
(In reply to comment #6)
> Well, this bug (its second half, that is) is about opening detached attachments
> whose type is "message/rfc822". I couldn't find any bug on this.

Sounds like it might be bug 271094. 
Please, ony issue per bug. 

You need to log in before you can comment on or make changes to this bug.