caret of an Inputfield overlapping an IFrame disappears

RESOLVED DUPLICATE of bug 167801

Status

()

RESOLVED DUPLICATE of bug 167801
13 years ago
13 years ago

People

(Reporter: Roessler.Andreas, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

If there is an IFrame and an InputField which overlaps the IFrame using absolut
positioning the caret of the InputField disappears in the overlapping zone.
This can be easily reproduced by following short HTML code:

<html><body>
<iframe style="height: 200;width: 200;" src="about:blank"></iframe>
<div style="position: absolute; z-index: 100; top: 100px; left: 50px; width:
500px" >
<input type="text" 
 value="The caret of this InputField appears only outside the overlap-zone with
the IFrame" 
 style="width: 100%"/>
</div>
</body></html>

Reproducible: Always

Steps to Reproduce:
1. Paste the simple HTML coding of the "details" section in an HTML file
2. Load the file in the browser
3. Click in the InputField in the overlapping-zone and the caret won't be visible
4. Move the caret to the none-overlapping-zone and the caret will appear

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 167801 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.