Closed Bug 308205 Opened 15 years ago Closed 11 years ago

Script may be busy do you wish to stop script

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: cpthowdy71, Unassigned)

References

()

Details

Attachments

(2 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

It should work I have nothing else to tell

Reproducible: Sometimes

Steps to Reproduce:
1.I just go to the page and it pops up
2.
3.

Actual Results:  
nothing on playstation sit but on gimp site it wont view page
This is probably not a FireFox problem but rather a problem with the script on
that page. That popup happens when a script is taking too long to execute with
no results returning.
Component: JavaScript Console → General
QA Contact: javascript.console → general
what is the default time before you see this alert? is it 10 sec? what is the value in IE?
I see it more often than before after FF 1.5. did the value of this parameter changed (got smaller than before)?
when I try to reorganized my BMs in paces I get another error (to be screenshot posted shortly then this script run error. Pressing continue closes the popup but you cannot close window and script error reappears. Must crashout. 

using Minefield 2006041604 Win XP SP2
Attached image error when click on BM (obsolete) —
To recreate: bookmarks>organizebookmarks>expand folder>click on BM

Minefield build 2006041604
WinXP SP2
Attached image error when click on BM
To recreate: bookmarks>organizebookmarks>expand folder>click on BM
Occurs before script error problem

Minefield build 2006041604
WinXP SP2
Attachment #218638 - Attachment is obsolete: true
i am 65 year old pensioner just learning about computers so how do i fix script problems in fire fox
Do you still see this problem using firefox 2?
  (note: reporter email address is dead)

(In reply to comment #2)
> what is the default time before you see this alert? is it 10 sec? what is the
> value in IE?
> I see it more often than before after FF 1.5. 

FF 1.5 default for dom.max_script_run_time was 5 sec.
FF 2 and up default is 10 sec 
(bug 335058)

I get this often on Firefox, not on IE and not when I check the box in options not allowing colors to be changed...

 Sally
I heard it may be a system bug, try spyware update.. 
(In reply to comment #1)
> This is probably not a FireFox problem but rather a problem with the script on
> that page. That popup happens when a script is taking too long to execute with
> no results returning.

Indeed. However, if there are certain websites on which the alert pops up and you think this is an actual bug, please report it.

About Places: The bugs described here were encountered a lot when it was in development, but since Fx3 it's stable. If you still encounter a problem that may be a bug, please don't hesitate to report it.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.