[Mac] Use .download format for unfinished downloads

RESOLVED DUPLICATE of bug 71657

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 71657
13 years ago
10 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/412.7 (KHTML, like Gecko) Safari/412.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20050910 Firefox/1.6a1

The .download format should be used for unfinished downloads in order to better integrate with OSX. If 
we fully used the .download format than the user would be able to see the progress of a download just by 
looking at the icon. It also makes it much more evident to the user that the file they see is of an unfinished 
download, as opposed to the way it is done now.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

13 years ago
Created attachment 195785 [details]
A screenshot showing the format in action

Updated

13 years ago
Summary: Use .download format for unfinished downloads → [Mac] Use .download format for unfinished downloads

Comment 2

13 years ago
I don't believe that the icon updating is "automatic". We have to set the file
type on the file as the download progresses (and we'd have to provide a set of
icons for them).

Comment 3

13 years ago
(In reply to comment #2)
> I don't believe that the icon updating is "automatic". We have to set the file
> type on the file as the download progresses (and we'd have to provide a set of
> icons for them).

This is a dupe of bug 71657. There's no such thing like a '.download' format
with an automatically updated icon. It's just a trick with different icons.

*** This bug has been marked as a duplicate of 71657 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.