iframe size renders incorrect

RESOLVED INVALID

Status

()

Core
Layout
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: David Becker, Unassigned)

Tracking

({qawanted})

1.8 Branch
PowerPC
Mac OS X
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

When viewing an e-mail with the mailblocks web-mail service, there is a popup
window with an iframe that does not render correctly under FF 1.5b1.  It does
not fill the proper amount of space.  This used to work find under 1.0.x.

Reproducible: Always

Steps to Reproduce:
1. Login to your mailblocks account.
2. Click on a mail message.
3. Observe the popup window.

Actual Results:  
The body of the mail (an iframe, I believe) does not full the popup as it used
to under 1.0.x.  It also fails to resize when resizing the popup window.

Expected Results:  
iframe should fill the available space in the window.

See attached screen shot.
(Reporter)

Comment 1

13 years ago
Created attachment 195790 [details]
Screen shot of problem
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → 1.8 Branch
Need an actual HTML testcase attached to this bug...
Keywords: qawanted
The site doesn't load for me.
(Reporter)

Comment 4

13 years ago
Mailblocks has closed their doors and are no longer open for business.  However, you can see similar odd iframe behavior on the left hand portion of http://blogs.msdn.com/ ...
Created attachment 207222 [details]
screenshot

You mean this part that now shows a scrollbar?
(Reporter)

Comment 6

13 years ago
Sort of.  Judging from your screenshot, you're not using a Mac, which is what I filed this report under.  On a Mac, all of the navigation sections on the left hand side display scrollbars (though they're disabled).  It would seem that on Windows (?) only that one section shows them.  It didn't used to do that before 1.5...
On Windows XP here I see scrollbars on all of the divs (those aren't iframes at all).

Prior to 1.5 we didn't support the overflow-x CSS property, which this site uses.  That causes overflow to be set to "auto" for the y direction (per CSS spec), which means you see scrollbars, since the divs do overflow due to the 15px bottom padding on the anchor in the last line of the div).

So things are working just like they should given that CSS and markup.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.