Typing an apostrophe in text fields causes strange behavior.

RESOLVED DUPLICATE of bug 307375

Status

()

RESOLVED DUPLICATE of bug 307375
13 years ago
10 years ago

People

(Reporter: qfg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

In several message boards including that one, the apostrophe key sometimes acts
like a tab key or opens the find menu in firefox.

Reproducible: Sometimes

Steps to Reproduce:
1. type in apostrophe in the text field


Actual Results:  
it either opened the find menu and the apostrophes went in there or it also
jumped the cursor to different boxes like the tab key would do if it were pressed.

Expected Results:  
just put in the right character.

Comment 1

13 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050912
Firefox/1.6a1 ID:2005091207

Tab-based navigation for that forum is kinda screwy (it would be much better if
web developers learned to use tab order effectively).  Can you double check to
make sure that the problem isn't caused by you trying to tab around the form? 
Also, it would be handy if you could give an exact sequence of characters that
causes the problem and indicate which text box you are entering your text into.
(Reporter)

Comment 2

13 years ago
Hi,
I also tried doing the same thing (typing one apostrophe character) and it pulls
up the find menu on the forum.

It only happens when typing in any of the fields for the new message (subject,
description, and text)

The problem is it doesn't happen every time i try it. Also, the fields on this
page don't seem to have that problem.

Comment 3

13 years ago
I still cannot reproduce this bug.  Are you logged on when creating the new post
on the forum listed above?  Any information you can provide will be helpful.
(Reporter)

Comment 4

13 years ago
Well, now i cannot reproduce it at all.  Yes, i was logged in as well..
i will add as much info as i can if this happens again; very strange!

Comment 5

13 years ago
I have noticed this bug as well.  When typing in a textarea, if I type an
apostrophe, it pulls up the Find dialog and discontinues typing.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

Comment 6

13 years ago
Moving this to Firefox/Find Toolbar.
Component: General → Find Toolbar / FastFind
Summary: Typing in the apostrophe in text fields causes strange behavior. → Typing an apostrophe in text fields causes strange behavior.

Comment 7

13 years ago
*** Bug 308373 has been marked as a duplicate of this bug. ***

Comment 8

13 years ago
I missed the fact that this is a duplicate earlier.  Marking as such.

*** This bug has been marked as a duplicate of 307375 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 9

13 years ago
*** Bug 308229 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 10

13 years ago
I have been able to duplicate this behavior by:

copying the URL from the address bar by double clicking with the mouse to select
the whole line, then hitting Ctrl-C.

then i try to paste it into the text box of the message board and then that does
not work (either by Ctrl-V or right clicking and trying to click on paste). 

after this i tried to see if hitting the apostrophe would bring up the find box
and it did just that; at least it happened this time...

Comment 11

13 years ago
Please post all comments concerning this behavior at bug 307375.
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.