Initial account setup does not prompt for SSL requirements

RESOLVED DUPLICATE of bug 297278

Status

RESOLVED DUPLICATE of bug 297278
13 years ago
13 years ago

People

(Reporter: kderby2000, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

When setting up the first/initial account, the user is not prompted for their
SSL and/or port requirements.  However, upon completion of the login
information, Thunderbird immediately logs into the account.  This means that the
un/pw is passed unencrypted over the wire during the initial setup.  This may
also cause a novice user, who's not comfortable going any deeper than the intial
setup wizard, to have to make their way through the acct config screens to
activate SSL.

Reproducible: Always

Steps to Reproduce:
1. Install Thunderbird
2. After setup is complete, begin by selection "Email Account"
3. Once the email address, server names, etc. are entered, after clicking
next/finish, TB immediately checks for folders, new messages, etc.

SSL is only enabled by going deeper into the acct mgmt screen.



Expected Results:  
The initial acct setup wizard should ask for the user's SSL requirements.

Comment 1

13 years ago
Related to/duplicate of bug 297278 and bug 221030?
(Reporter)

Comment 2

13 years ago
Yes, it is a duplicate of 297278.  Pls ignore.

*** This bug has been marked as a duplicate of 297278 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.