If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash on migrating mail profile from Seamonkey

RESOLVED DUPLICATE of bug 285305

Status

Thunderbird
Migration
--
critical
RESOLVED DUPLICATE of bug 285305
12 years ago
12 years ago

People

(Reporter: Peter Edman, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20050910 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20050910 Firefox/1.6a1

Decided to take the opportunity of Thunderbird 1.5beta to experiment with
leaving Seamonkey. Downloaded and opened the program (which, by the way, opened
itself and a dialog box in the background. Had to flip around to see that the
program was running. BAD!). 

Was asked whether to import profiles; checked Mozilla 1.0; checked my main
profile (which is not a default). Clicked ok. Crash. 

Repeated three times after deleting prefs and such. 

The one time I tried restarting Thunderbird, the program opened but it then went
into the "create a new account" wizard-thingy. It had not imported my Seamonkey
mail, and it didn't give me another try. Trackback did not run. 

Reproducible: Always

Steps to Reproduce:
1. Open fresh copy of Thunderbird with no previous prefs or profile
2. Select Mozilla Profile to Import
3. Hit OK

Actual Results:  
Crash

Expected Results:  
migrated profile and imported old mail

This is part of the printout from the OS X crash report: 

Date/Time:      2005-09-12 22:53:02.363 -0400
OS Version:     10.4.2 (Build 8C46)
Report Version: 3

Command: thunderbird-bin
Path:    /Applications/Thunderbird.app/Contents/MacOS/thunderbird-bin
Parent:  launchd [1]

Version: 1.4 (1.4)

PID:    13707
Thread: 0

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

Thread 0 Crashed:
0   org.mozilla.thunderbird  	0x00829fd4
nsNetscapeProfileMigratorBase::RecursiveCopy(nsIFile*, nsIFile*) + 24
1   org.mozilla.thunderbird  	0x0044b6a4
nsSeamonkeyProfileMigrator::CopyMailFolders(nsVoidArray*, nsIPrefService*) + 1564
2   org.mozilla.thunderbird  	0x0044a8b0
nsSeamonkeyProfileMigrator::TransformPreferences(nsAString_internal const&,
nsAString_internal const&) + 640
3   org.mozilla.thunderbird  	0x0044ba7c
nsSeamonkeyProfileMigrator::CopyPreferences(int) + 116
4   org.mozilla.thunderbird  	0x00449aa8
nsSeamonkeyProfileMigrator::Migrate(unsigned short, nsIProfileStartup*, unsigned
short const*) + 296
5   libxpcom_core.dylib      	0x1005cfbc _XPTC_InvokeByIndex + 216
6   org.mozilla.thunderbird  	0x00561820
XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode) + 2508
7   org.mozilla.thunderbird  	0x005552a8 XPC_WN_CallMethod(JSContext*,
JSObject*, unsigned, long*, long*) + 220
8   libmozjs.dylib           	0x0602ca70 js_Invoke + 1768
9   libmozjs.dylib           	0x06034aa4 js_Interpret + 28788
10  libmozjs.dylib           	0x0602cab4 js_Invoke + 1836
11  libmozjs.dylib           	0x0602ccc0 js_InternalInvoke + 184
12  libmozjs.dylib           	0x06007b10 JS_CallFunctionValue + 44
13  org.mozilla.thunderbird  	0x00382720
nsJSContext::CallEventHandler(JSObject*, JSObject*, unsigned, long*, long*) + 284
14  org.mozilla.thunderbird  	0x0037a694 nsGlobalWindow::RunTimeout(nsTimeout*)
+ 744
15  org.mozilla.thunderbird  	0x0037adf8
nsGlobalWindow::TimerCallback(nsITimer*, void*) + 40
16  libxpcom_core.dylib      	0x10049c50 nsTimerImpl::Fire() + 168
17  libxpcom_core.dylib      	0x10049d78 handleTimerEvent(TimerEventType*) + 140
18  libxpcom_core.dylib      	0x10045ca4 PL_HandleEvent + 36
19  libxpcom_core.dylib      	0x10045bc8 PL_ProcessPendingEvents + 128
20  com.apple.CoreFoundation 	0x9074bc8c __CFRunLoopDoSources0 + 384
21  com.apple.CoreFoundation 	0x9074b1bc __CFRunLoopRun + 452
22  com.apple.CoreFoundation 	0x9074ac3c CFRunLoopRunSpecific + 268
23  com.apple.HIToolbox      	0x93129ac0 RunCurrentEventLoopInMode + 264
24  com.apple.HIToolbox      	0x9320e768 GetNextEventMatchingMask + 400
25  com.apple.HIToolbox      	0x9320e51c WNEInternal + 140
26  com.apple.HIToolbox      	0x9320e47c WaitNextEvent + 76
27  org.mozilla.thunderbird  	0x0082ac20
nsMacMessagePump::GetEvent(EventRecord&) + 116
28  org.mozilla.thunderbird  	0x0044d28c nsAppShell::GetNativeEvent(int&,
void*&) + 60
29  org.mozilla.thunderbird  	0x0089f944 nsXULWindow::ShowModal() + 456
30  org.mozilla.thunderbird  	0x003fa5e4
nsWindowWatcher::OpenWindowJS(nsIDOMWindow*, char const*, char const*, char
const*, int, unsigned, long*, nsIDOMWindow**) + 3460
31  org.mozilla.thunderbird  	0x003f982c
nsWindowWatcher::OpenWindow(nsIDOMWindow*, char const*, char const*, char
const*, nsISupports*, nsIDOMWindow**) + 140
32  org.mozilla.thunderbird  	0x0044c7c8
nsProfileMigrator::Migrate(nsIProfileStartup*) + 524
33  org.mozilla.thunderbird  	0x0000e644 XRE_main + 2152
34  org.mozilla.thunderbird  	0x0000a01c start + 432
35  org.mozilla.thunderbird  	0x00009e9c start + 48

Thread 1:
0   libSystem.B.dylib        	0x9001efec select + 12
1   libnspr4.dylib           	0x0301f140 poll + 392
2   libnspr4.dylib           	0x0301b8f4 PR_OpenDir + 944
3   org.mozilla.thunderbird  	0x005305c4
nsSocketTransportService::Poll(unsigned*) + 116
4   org.mozilla.thunderbird  	0x00530d10 nsSocketTransportService::Run() + 432
5   libxpcom_core.dylib      	0x100488c4 nsThread::Main(void*) + 56
6   libnspr4.dylib           	0x0301cd80 PR_Select + 852
7   libSystem.B.dylib        	0x9002c3d4 _pthread_body + 96

Thread 2:
0   libSystem.B.dylib        	0x90056418 semaphore_timedwait_signal_trap + 8
1   libSystem.B.dylib        	0x90056284 pthread_cond_timedwait + 704
2   libnspr4.dylib           	0x03017c68 PR_Unlock + 300
3   libnspr4.dylib           	0x03017ecc PR_WaitCondVar + 136
4   libxpcom_core.dylib      	0x1004b4b0 TimerThread::Run() + 412
5   libxpcom_core.dylib      	0x100488c4 nsThread::Main(void*) + 56
6   libnspr4.dylib           	0x0301cd80 PR_Select + 852
7   libSystem.B.dylib        	0x9002c3d4 _pthread_body + 96

Thread 3:
0   libSystem.B.dylib        	0x90056418 semaphore_timedwait_signal_trap + 8
1   libSystem.B.dylib        	0x90056284 pthread_cond_timedwait + 704
2   libnspr4.dylib           	0x03017c68 PR_Unlock + 300
3   libnspr4.dylib           	0x03017ecc PR_WaitCondVar + 136
4   org.mozilla.thunderbird  	0x004eee68 nsIOThreadPool::ThreadFunc(void*) + 116
5   libnspr4.dylib           	0x0301cd80 PR_Select + 852
6   libSystem.B.dylib        	0x9002c3d4 _pthread_body + 96

Thread 0 crashed with PPC Thread State 64:

[there's more; I can provide the rest on request]

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 285305 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.