Removing name or ID attr on input doesn't remove name from form

RESOLVED FIXED in mozilla1.9alpha1

Status

()

Core
DOM
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: bz, Assigned: bz)

Tracking

Trunk
mozilla1.9alpha1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Testcase in URL field should explain it all...  Basically, we do stuff in
nsGenericHTMLFormElement::SetAttr that we don't do in UnsetAttr.

Comment 1

13 years ago
Duplicate of bug 100499, isn't it?
No.  That bug is about the stale ref after you've gotten by name once and have
changed it.  This bug is about a stale ref if you've _never_ gotten by name and
then _remove_ it.  Quite different bugs, with totally different underlying code
reasons.
Fixed by checkin for bug 308270
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9alpha
You need to log in before you can comment on or make changes to this bug.