Closed Bug 308293 Opened 14 years ago Closed 14 years ago

LDAP support is totally broken

Categories

(Thunderbird :: Address Book, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: Petr, Assigned: mscott)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc3 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc3 Firefox/1.0.6

When TB 1.5b1 is configured to use ldap directory for address book
(the same way as TB 1.0.6 working fine), it is not working.

Reproducible: Always

Steps to Reproduce:
1. Configure TB to use ldap directory for address book
2. Try to search something


Actual Results:  
No matches found.

Expected Results:  
Should return some data. For search '*' should return first 200 records.

TB doesnt contact the ldap server. No ldap bind or search packet on wire.
TCPdump records big silent.
LDAP support was broken during the #119291 fix, I guess.
that's weird. It's working fine here for me. 
Are we even tcp connecting to the ldap server? Is your server a ldapv2 or ldapv3
server? Are you using the same profile as works in 1.06?
Summary: LDAP support is totaly broken → LDAP support is totally broken
Version: unspecified → 1.5
mscott, thanks for report.

Client is WinXP+SP2+updates, server OpenLDAP 2.2.13 on linux.
TB 1.0.6 and TB 1.5b1 works fine until using IPv4 only.

When I did open Win "DOS box window" (Run program -> cmd)
and run "ipv6 install", the Address Book stops working.

After enter some string to search in adressbook,
nothing to happens and tcpdump shows ICMPv6 "Neighbor solicitation"
packets only.
The rest of all programs and applications works fine over IPv6.

Dont know what is wrong.
I think the IPv6 issue with LDAP is known.
here's a MZ thread complaining about LDAP. I still can't reproduce this against
my LDAP test servers in the AB.

http://forums.mozillazine.org/viewtopic.php?t=316423
Looks like it is general IPv6 related problem.
It needs more investigation, so Im going to close
this bug as invalid and will create new bug eventually.

Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.