Bookmarks.plist causes Camino to crash immediately upon launch

VERIFIED WORKSFORME

Status

Camino Graveyard
General
--
critical
VERIFIED WORKSFORME
13 years ago
13 years ago

People

(Reporter: erin, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

({crash})

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/85.8.5 (KHTML, like Gecko) Safari/85.8.1
Build Identifier: 

When I try to launch Camino, it attempts to launch, but then fails and displays the message "The 
application Camino has unexpectedly quit.  The system and other applications have not been 
affected."

I have restarted, and have also attempted to re-install Camino.

The first time this happened was when I was trying to launch Camino while Carbon Copy Cloner 
was creating a clone of my hard drive to an external hard drive.  

Reproducible: Always

Steps to Reproduce:
1. Click on Camino icon to launch application.
2.  
3.
Actual Results:  
Camino displays "unexpectedly quit" message

Expected Results:  
It should have launched Camino.
Can you get a crash log as described here:
http://www.caminobrowser.org/support/sup_bugzilla.html
and attach it to this bug?

Also, what version of Camino were you attempting to run?
(Reporter)

Comment 2

13 years ago
Sorry, I wanted to add the version number, but I don't know what version of Camino it is, and now I 
cannot open the Camino application in order to find out.

Is there any way to find out the version number without opening the application?
> Is there any way to find out the version number without opening the application?

Select the application in the Finder and then choose "Get Info" from the "File"
menu.
(Reporter)

Comment 4

13 years ago
The version I have recently installed (which also will not launch) is version 0.8.4.

I am not sure that this is the same version I was using when I first had this problem.  I deleted that 
from my Applications folder when I was trying to re-install Camino.

Sorry this is such a mess...
Can you please get us a crashlog (see comment 1)?

You might also try moving aside the "Camino" folder in your user's
~/Library/Application Support folder and letting Camino try to create a new
profile, in case something in there was causing the crash (it's hard to say
without a crashlog).
(Reporter)

Comment 6

13 years ago
Based on the last comments from alqahira@mindspring.com, I renamed the "Camino"
folder in my -/Library/Application Support folder, then re-opened Camino.  It
did open this time.  I tried to copy over the old bookmarks.plist file, but that
seems to be what was crashing the application.  So I've had to start over with
my bookmarks, which is a bummer, but at least I can use Camino again.

So I have a work-around for this bug.

Thanks for the help!

Erin
Do you still have the problematic bookmarks.plist?  If so, can you attach it to
this bug using the "Create New Attachment" link?
Keywords: crash
Summary: Camino application crashes immediately upon launching: "The application Camino has unexpectedly quit" → Bookmarks.plist causes Camino to crash immediately upon launch
(Reporter)

Comment 8

13 years ago
Sorry!  I didn't think to save it.  I certainly regret this.  If I have the
problem again, I will save it and send to you.

I appreciate your help, and I'm sorry I didn't save the problematic file for you.

Comment 9

13 years ago
Don't have data to reproduce.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 10

13 years ago
gor!
You need to log in before you can comment on or make changes to this bug.