tspan bugs/missing features

RESOLVED FIXED

Status

()

Core
SVG
RESOLVED FIXED
12 years ago
a year ago

People

(Reporter: Martin Kroeker, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.4; Linux) KHTML/3.4.1 (like Gecko)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

The mozilla svg status page does not explicitly mention that the 
baseline-shift attribute is not implemented. 
Trying to work around this for sub/superscripts, i noticed that 
- <tspan y="..."> resets the x position to the start of the string instead 
of keeping its current value when no new x="..." is given 
- when changing the font-size in a tspan, the text length is apparently not 
calculated correctly, creating a large gap around smaller characters   

Reproducible: Always

Comment 1

12 years ago
This is duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=308338

Comment 2

12 years ago
Actually, it's not duplicate, it's about different bugs. Sorry for the noise.

Comment 3

11 years ago
If I understand correctly this is exactly the missing feature I am also 
experiencing right now. To make it a little more clear here an example 
of what will go wrong. The following code snipet:

<tspan x="10 20 30 40">HELP</tspan>

I expected this piece to be rendered with each character at the given
x position. What happens is that the first character is put at the
proper location but the other ones are just put using the standard
characterwidth but not the given position. It has nothing to do with the
baseline-shift attribute.
(In reply to comment #3)
> If I understand correctly this is exactly the missing feature I am also 
> experiencing right now. To make it a little more clear here an example 
> of what will go wrong. The following code snipet:
> 
> <tspan x="10 20 30 40">HELP</tspan>
> 
> I expected this piece to be rendered with each character at the given
> x position. What happens is that the first character is put at the
> proper location but the other ones are just put using the standard
> characterwidth but not the given position. It has nothing to do with the
> baseline-shift attribute.
> 

You are describing a different bug i.e. bug 311986. This bug is about resetting the x position in different tspan fragments.

Assignee: general → nobody
QA Contact: ian → general
Fixed by bug 333698
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

a year ago
Duplicate of this bug: 1307680
You need to log in before you can comment on or make changes to this bug.