floated table within table changes size when clicking on a link

RESOLVED DUPLICATE of bug 307387

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 307387
13 years ago
13 years ago

People

(Reporter: Cesar Eduardo Barros, Unassigned)

Tracking

({regression, testcase})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

(Also reported as RMO11266490488018)

Clicking on a link on the table to the right ("Supplementary Manuals") sometimes
causes the table to change its size (while before all rows had a single line,
now some rows have two lines, which allows the table to shrink). This only
happens when the table is wider (all rows with a single line). Both left click
and right click show the same behaviour.

For some reason, I've found the table loads with the wider size when the URL is
entered on the address bar, but sometimes not when loaded via a link. This bug
will only show when the table happens to have the wider size.

Reproducible: Sometimes

Steps to Reproduce:
1. Load the testcase or the URL.
2. Verify the table to the right ("Supplementary Manuals") has only one line per
row. If not, try loading from the address bar.
3. Click with either mouse button on a link on the table (for instance, "Dashes").

Actual Results:  
The longer rows on the table are split in the middle, making it shrink horizontally.

Expected Results:  
The table should not change its size. Its rows should not change the line breaks.

If it makes any difference, I'm using an unusual DPI setting (132DPI, System
setting) and unusual font sizes (22px, in fact the default font size compensated
for the higher DPI).

I made a reduced testcase (which I will attach soon) where I removed most of the
parts of the page not relevant for this bug report (including all the external
CSS and Javascript). Playing with it, I noticed that either removing the outer
table or the "float:right" on the inner table avoids the problem.
(Reporter)

Comment 1

13 years ago
Created attachment 195963 [details]
reduced testcase

Reduced testcase. Either removing the outer table or removing the "float:right"
from the inner table makes the bug not show.

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 307387 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

13 years ago
Works on 1.0.6; marking as regression.
Keywords: regression
(Reporter)

Updated

13 years ago
Keywords: testcase
You need to log in before you can comment on or make changes to this bug.