SeaMonkey completely exits when closing Navigator

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: u107962, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050910 SeaMonkey/1.0a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050910 SeaMonkey/1.0a

In Win XP SP2 with quick launch turned on, system tray icon disappears after
closing all open SeaMonkey windows. quick launch appears to not be turning on
because the splash screen appears and the usual pause afterwards while the suite
is loading when, say, Navigator is opened again

Reproducible: Always

Steps to Reproduce:
1.Open Navigator. 
2.go to Preferences, and check box for quick launch. (regardless of if it's
previously been turned on)
3.Close Preferences by clicking "OK"
4.Note SeaMonkey icon in system tray.
5.Browse some websites. The number doesn't seem to matter.
6.Close Navigator and every other open SeaMonkey component.
Actual Results:  
Icon disappears, as usual, from system tray. However, it doesn't come back after
a moment or two. It doesn't reappear until quick launch is turned off, then back
on in Preferences. Seamonkey.exe no longer listed in task manager as a running
process. Restarting SeaMonkey causes splash screen to load and a brand new
instance of SeaMonkey to run because the first one isn' running.

Expected Results:  
stayed in memory and system tray icon not disappeared

Comment 1

13 years ago
WFM with SeaMonkey/20050910/1.0a and SeaMonkey/20050913/1.1a, maybe related to
Core bug 303187?
(Reporter)

Comment 2

13 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4)
Gecko/20050910 SeaMonkey/1.0a
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4)
Gecko/20050910 SeaMonkey/1.0a
> 
> In Win XP SP2 with quick launch turned on, system tray icon disappears after
> closing all open SeaMonkey windows. quick launch appears to not be turning on
> because the splash screen appears and the usual pause afterwards while the suite
> is loading when, say, Navigator is opened again
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1.Open Navigator. 
> 2.go to Preferences, and check box for quick launch. (regardless of if it's
> previously been turned on)
> 3.Close Preferences by clicking "OK"
> 4.Note SeaMonkey icon in system tray.
> 5.Browse some websites. The number doesn't seem to matter.
> 6.Close Navigator and every other open SeaMonkey component.
> Actual Results:  
> Icon disappears, as usual, from system tray. However, it doesn't come back after
> a moment or two. It doesn't reappear until quick launch is turned off, then back
> on in Preferences. Seamonkey.exe no longer listed in task manager as a running
> process. Restarting SeaMonkey causes splash screen to load and a brand new
> instance of SeaMonkey to run because the first one isn' running.
> 
> Expected Results:  
> stayed in memory and system tray icon not disappeared

Actually, problem fixed itself after a reboot. Stupid me. I forgot to reboot
after uninstalling Mozilla1.7.11 and installing SeaMonkey1.0a. Mabe there should
be a dialog box forcing (or at least assertively suggessting) reboot after
installation like most other Windows programs have.

Comment 3

13 years ago
Surem you have to reboot the first time (or at least relogin).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.