pink lines in a page where there shouldn't be any

RESOLVED INVALID

Status

--
trivial
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: thehecwithyou, Assigned: mikepinkerton)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050912 Camino/1.0a1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050912 Camino/1.0a1

In this page, there are two pink boxes around the form fields when there
shouldn't be any pink boxes. These boxes don't come out on Firefox.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.thefacebook.com/ and login.
2. Click on Search on the menu bar.
3. Select advanced in the submenu.

Actual Results:  
The advanced search page does, indeed, have pink bars.

Expected Results:  
Camino shouldn't have shown any pink lines, like in Firefox.

Comment 1

13 years ago
From the CSS at http://www.facebook.com/css/search.css :

.advancecolumn {
        float: left;
        width: 250px;
        padding: 0px;
        outline: solid 1px hotpink; }

It appears to me that we're doing the right thing, and Firefox isn't, somehow.
Wht I don't understand is why Gecko is behaving differently, since both browsers
are using the same rendering back end.

Are you using any ad-blocking or anything like that? If so, try disabling it
(both browsers) and see if you get the same results.

cl
Are you comparing identical builds of Camino and Firefox?  Is the site feeding
both browsers the same content?
(Reporter)

Comment 3

13 years ago
Chris: I'm not using any sort of adblocking programs. I also tried it in Safari
and it doesn't show the pink bars.(In reply to comment #1)

Smokey: The site is feeding Camino the pink bars, Firefox isn't displaying it,
neither have any of the other browsers I use (Safari, IE). I'm not sure I
understand the question about the build, but this is the info on my Firefox:
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.9) Gecko/20050711
Firefox/1.0.5(In reply to comment #2)
You'll need to download Firefox 1.5 beta 1 to test with for it to be comparable
with the Camino build you're using. Please report back if you see them in FF
1.5b1 as well. Thank you.

(In reply to comment #3)
> Firefox: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.9) 
> Gecko/20050711 Firefox/1.0.5(In reply to comment #2)

(Reporter)

Comment 5

13 years ago
It also happens in Firefox 1.5b1.
OK, I just registered and see the pink bars in both.  Based on what I see and
Chris's comment 1, this seems like a bug in Gecko 1.7 that was fixed for Gecko
1.8 (both Cm 1.0a1 and Fx 1.5b1 are doing the right thing, and Safari is not; I
don't think Gecko supported "outline" in 1.7, and at least Safari 1.3.x still
doesn't).  

You should contact the site and let them know.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.