Using "document.documentElement.offsetParent" causes crash

VERIFIED FIXED

Status

()

P3
critical
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: hakan.nilsson, Assigned: vidur)

Tracking

({crash})

Trunk
x86
Windows NT
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows NT)
BuildID:    20000022820

using "document.documentElement.offsetParent" crashes the M14, M12 
returns "undefined"

Reproducible: Always
Steps to Reproduce:
1. Load page and it will show
2.
3.

Actual Results:  crash

Expected Results:  anything but crash, maybe return "undefined" och null och 
nothing.

cant find parentOffset in DOM-spec och ECMA-binding

Comment 1

19 years ago
According to W3C DOM Level-1 specs, offsetParent is not a DOM object property. I 
couldn't find it in level-2, or JavaScript either. Hakan, where does it come 
from?
(Reporter)

Comment 2

19 years ago
Sorry! :/ Got my IE5 and Mozilla mixed up (offserParent is a IE-Specific 
property) it isnt a part of Mozilla, DOM or JS (but somehow it seems to break 
M14)

A found "the bug" when I was trying to get my primitive DOM-analyze-page to 
work with IE5 and M14 (it was working fine with M12)
http://www.algonet.se/~delphi/mozilla/document_view.html
http://www.algonet.se/~delphi/mozilla/document_view2.html

I will try to break it down further and check back when I find the "true" bug...
However M14 still crashes when calling (document.documentElement.offsetParent) 
and that is no good :/
hakan.nilsson@programmer.net - although we aren't implementing IE-specific stuff, 
is Mozilla still crashing when presented with this?

Gerv
Crashes 40000418 (M15) under W95.

MOZILLA caused an invalid page fault in
module GKHTML.DLL at 015f:601d7afb.
Registers:
EAX=00000000 CS=015f EIP=601d7afb EFLGS=00010246
EBX=00000000 SS=0167 ESP=0068edec EBP=0068ee08
ECX=008cf660 DS=0167 ESI=00000000 FS=3a2f
EDX=00000000 ES=0167 EDI=00000000 GS=0000
Bytes at CS:EIP:
8b 08 68 c8 a7 2c 60 50 ff 11 8b f0 8d 4d fc e8 
Stack dump:
0068eed8 80000000 00000000 00000000 00000400 00000259 00000000 0068eec8 60280950 
0068eed8 60b44788 009186b0 0068eed8 0068f064 0000003c 00a039f0 

Adding crash keyword, upgrading severity, confirming.

Gerv
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash
Summary: crash if I try to read value from "document.documentElement.offsetParent" → Using "document.documentElement.offsetParent" causes crash
I'm unable to reproduce this any more, I know I at least tried to fix this but I
don't remember when, marking FIXED, please reopen if it's still crashing.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 6

18 years ago
Mass update of qa contact
QA Contact: gerardok → janc

Comment 7

18 years ago
Verified:
2000-09-20-09-M18 : Windows
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.