Closed Bug 308492 Opened 17 years ago Closed 13 years ago

Tabbrowsing with miniature preview

Categories

(Firefox :: Tabbed Browser, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 465076

People

(Reporter: egonknapen, Unassigned)

References

Details

(Whiteboard: parity-opera parity-IE7)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

IE7 is going to offer a new feature, that enables one, by pressing a some key,
to show a page with a miniatur from every tab.

Reproducible: Always




Would be nice, to offer such a feature.

Should something like this be released in the browser or as an plugin (by using
the new canvas.drawWindow ?)
I would expect that this is something that an extension should be providing, the
tab preview extension already does something similar.
There is an extension for it, called tabPreview (I'm using it)
See http://forums.mozillazine.org/viewtopic.php?t=276207
Confirming as RFE.  My Tab Preview extension shows a preview of each background
tab when you hover your mouse over them.  I think this bug wants something
slightly different, like OS X's "expose", which shows a preview of all tabs.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Tabbrowsing with miniatur preview → Tabbrowsing with miniature preview
I was looking for the word expose, but couldn't find it last time.

But that is what I mean yeh.

Last time I checked that other extension didn't work yet under firefox 1.5 beta 1.
The Viamatic foXpose extension can do something similar.

http://viamatic.com/index.php/firefox
Foxpose is a great extension, and a tool like this one is included in IE7 beta2.

Foxpose is very light weight (something like 20 kb). It will be a great features for fx 2.0, isn't it ?
*** Bug 332278 has been marked as a duplicate of this bug. ***
Flags: blocking-firefox2?
Nobody's working on this and we're past alpha, so why would you ask for blocking?
Flags: blocking-firefox2?
(In reply to comment #8)
> Nobody's working on this and we're past alpha, so why would you ask for
> blocking?
> 

Is this the same thing as what came out on Seamonkey back in June? 

Tab preview is enabled by default. http://forums.mozillazine.org/viewtopic.php?t=432737
Opera 9 (maybe previous versions too) has this yet also has generally lower memory usage. IE7 miniaturizes the previews, but they aren't previewed under each tab, but loaded with others with "Quick Tabs".
Duplicate of this bug: 383172
Blocking-firefox3?, since this is now IE-parity and Opera-parity.
Flags: blocking-firefox3?
Whiteboard: {IE-parity} {Opera-parity}
What Opera and SeaMonkey do is completely different from what foXpose and IE do. (I don't think any of the given implementations is actually useful for browsing, but that's not my point.) It's not clear what this bug is about -- I suggest to solve that and find an assignee before requesting blocking.
Flags: blocking-firefox3?
Whiteboard: {IE-parity} {Opera-parity} → parity-opera parity-IE7
I think this is about the IE one (QuickTabs, or Tab Previews). I will open another bug for Opera-like SpeedDials. (Presumably it would be a good idea integrating SpeedDials with Bookmarks/Places, like with a context menu item on bookmark folders saying "Show as Gallery".) I think that SpeedDials (my name for it: Site Gallery) is wanted-firefox4, while this one is at least wanted-firefox3. We could easily do this one by integrating Firefox Showcase.
SpeedDial is a whole different story again. In fact, it has nothing to do with tabbed browsing. What I meant is the preview image when hovering over a tab.

I'm not sure why you think tab previews à la QuickTabs are "at least wanted-firefox3". Are there any references beyond this bug?
Depends on: 465076
Isn't this fixed with the tab-switching widget in FFx Namoroka?
(In reply to comment #16)
> Isn't this fixed with the tab-switching widget in FFx Namoroka?

The current implementation isn't there yet, but it's being worked on. Duping against bug 465076.
Status: NEW → RESOLVED
Closed: 13 years ago
No longer depends on: 465076
Resolution: --- → DUPLICATE
Duplicate of bug: 465076
You need to log in before you can comment on or make changes to this bug.