Back/Forward dropdown menus fail to disapear when used with single mouse action.

RESOLVED DUPLICATE of bug 102330

Status

RESOLVED DUPLICATE of bug 102330
13 years ago
13 years ago

People

(Reporter: IDontUseMozillaAnyMore, Assigned: jag+mozilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050702
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050702

If you click on the 'down pointing triangle' of the back or forward buttons to
obtain the dropdown menu it doesn't always dissapear. It seems to be when you
mouse down on the arrow and then select a menu entry an only then release the
mouse, as apposed to clicking the triangle and then further clicking the item
from the menu.

Reproducible: Always

Steps to Reproduce:
1. Open a browser window and navigate a few pages to provide a back button.
2. Mouse down on the back button triangle to obtain the dropdown menu.
3. Without releasing the mouse button, drag an item in the back history.
4. Release the mouse button to select that page.
Actual Results:  
The correct page is displayed in the browser window but the back menu remains
visible.

Expected Results:  
The back menu should disapear once a selection is made.

If you click the triangle (mouse-down followed by mouse-up) and then make a
selection all works correctly. I have not been able to check this on a Windows
box so I'll leave this as MacOS only. Traditional Mac users are used to this
single motion approach to menus so will find this particularly odd behaviour.

Try selecting the last item in the menu when you do this. Because there is
nolonger anywhere to go back to the back button disables completely which means
there is no way to get rid of the dropdown menu!

The same is true of the forward button menu.

Comment 1

13 years ago
This was fixed for a month ago, should work fine with the mac SeaMonkey 1.0a
candidate at
http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/contrib/2005-09-10-12-mozilla1.8/

*** This bug has been marked as a duplicate of 102330 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.