Accented e in url converted to wrong value.

RESOLVED DUPLICATE of bug 284474

Status

()

defect
RESOLVED DUPLICATE of bug 284474
14 years ago
14 years ago

People

(Reporter: s.jolicoeur, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

The french accented e (é) is encoded to %C3%A9 (é) in the url bar. It should
really be %E9 (é).



Reproducible: Always

Steps to Reproduce:
1. Go to any url containing a accented e like
http://forum.quebecmicro.com/postlist.php?Cat=&Board=Matériel


Actual Results:  
The url is encoded to
http://forum.quebecmicro.com/postlist.php?Cat=&Board=Mat%C3%A9riel

Expected Results:  
The url encoding should of been
http://forum.quebecmicro.com/postlist.php?Cat=&Board=Mat%E9riel

The same (reported) wrong encoding appears in the bookmarks path when a french
accented e is used. (see bug #307628)
(Reporter)

Updated

14 years ago
Version: unspecified → 1.5 Branch

*** This bug has been marked as a duplicate of 284474 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.