Closed Bug 308659 Opened 15 years ago Closed 3 years ago

[MSI] Installer should repair the installation if files are missing/corrupt or deleted

Categories

(Firefox :: Installer, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 231062

People

(Reporter: harig.in, Unassigned)

References

Details

Install firefox.  Delete some files from the installation directory (say the
classic.jar or browser.jar etc.).  Launch firefox.  No errors are given. 
Firefox runs in memory without a window/visible indication.

Preferred behaviour: 

Firefox should allow the user to repair the installation.
How exactly should it repair the installation if you delete files necessary to
browser operation?
There is no way for the installer to do this without at least the app triggering it. For example your steps of:
Install firefox.  Delete some files from the installation directory (say the
classic.jar or browser.jar etc.).  Launch firefox.  No errors are given. 
Firefox runs in memory without a window/visible indication.

would require the app to trigger a repair.

MSI based installers can provide this functionality but the standard exe installer won't.
Adding dependency on implementing an MSI
Depends on: MSI
Summary: Installer should repair the installation if files are missing/corrupt or deleted → [MSI] Installer should repair the installation if files are missing/corrupt or deleted
Repair is working just fine in a MSI packages, created using my patch from bug 231062.

If a missing file is detected, we can just invoke msiexec with correct options. If the msi is in the system cache, it'll be enough. If the msi is not cached, we can offer to download one.

AFAICT, msi 2.0 and later will correctly prompt for admin pass, if invoked by LUA.
We would get this for free just by using MSI correctly, no need for a separate bug.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: MSI
You need to log in before you can comment on or make changes to this bug.