Crash: composing when signature file is pointed to a file on a windows disk

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: mozillabugs, Assigned: mscott)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050913 Firefox/1.0.6 (Ubuntu package 1.0.6)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050913 Firefox/1.0.6 (Ubuntu package 1.0.6)

When using thunderbird on linux with a profile created on Windows, TB crashes
when trying to write an email (be it a new one or a reply) when "Attach this
signature" is enabled, and the file location is in the form of c:\bug\sig.txt 

To be more precise: I had a signature enabled in windows, copied my profile
folder over to my new linux machine, and booted thunderbird with 

mozilla-thunderbird -safe-mode

to get past the fact that of course my skin was not there. When replying or
composing a mail with an identity which had 'Attach this signature' highlighted
in windows, it crashes.

Reproducible: Always

Steps to Reproduce:
1. Make profile on windows
2. Attach a signature to the identity
3. copy the profile folder to linux
4. Get firefox on linux to use all the settings (I did this by making a new
profile, and putting all the files from the windows profile there)
5. start with mozilla-thunderbird -safe-mode
6 quit
7. start thunderbird normally
8. compose a mail, and at least select the identity with the signature
Actual Results:  
Crash - thunderbird is closed.

Expected Results:  
compose an email :)
(Reporter)

Comment 1

13 years ago
Oh, and if I alter prefs.js, and set attach_signature to false, and remove
sig_file and sig_file-rel, the problem is solved.
It's not possible to share all of the profile between windows and linux, though
much of it works... 

Anyways, tried to reproduce, but couldn't get any crash. Using version 1.5 Beta
1 (20050915) /linux.

Updated

13 years ago
Severity: normal → critical
Keywords: crash
Summary: Crash: composing when sig-file is pointed to a file on a windows disk → Crash: composing when signature file is pointed to a file on a windows disk

Comment 3

13 years ago
(In reply to comment #2)
> It's not possible to share all of the profile between windows and linux, though
> much of it works... 
> 
> Anyways, tried to reproduce, but couldn't get any crash. Using version 1.5 Beta
> 1 (20050915) /linux.

I've got the same trouble, and solved the same way. Lines like thees where the cause:

--<cut from profiles.ini>--
[Profile0]
Name=Alberto
IsRelative=0
Path=/home/alberto/.mozilla-thunderbird-profiles/Alberto
Default=1

--<cut from prefs.js>--
user_pref("mail.identity.id1.sig_file", "D:\\Mis Documentos\\ThunderBird\\Alberto\\signatureOky.txt");
user_pref("mail.identity.id1.sig_file-rel", "[ProfD]../../../../../../../D:/Mis Documentos/ThunderBird/Alberto/signatureOky.txt");

tb crashes when composing/reply/forwarding *AND* in the main tab for the acount in the accounts setup.
->WFM, feel free to reopen if you can reproduce with 2.0. And if so, include a talkback id. <http://kb.mozillazine.org/Talkback>
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.