Status

()

--
critical
RESOLVED INVALID
13 years ago
12 years ago

People

(Reporter: marcel, Unassigned)

Tracking

({crash})

1.0 Branch
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050726 Epiphany/1.2.10
Build Identifier: Firefox 1.0.6

./firefox-installer: line 56:  7420 Segmentatie fout        ./${BINNAME}-bin $@

This is the error I get. I run Suse 9.2 Linux.

Reproducible: Always

Steps to Reproduce:
1. start the instraller
2. in the dialog: change the directory
3. 

Actual Results:  
./firefox-installer: line 56:  7420 Segmentatie fout        ./${BINNAME}-bin $@


Expected Results:  
Th software should be installed in the chose directory

Updated

13 years ago
Keywords: crash
Summary: Installer crashed evryone of the thousand times I tried → Installer crashes

Comment 1

13 years ago
can you get a stacktrace with gdb?
env LD_LIBRARY_PATH=. gdb firefox-installer-bin
(gdb)run
[crash]
(gdb)bt

paste the output of "bt" as an additional comment
(Reporter)

Comment 2

13 years ago
as requested: (gdb) bt output:
#0  0x4033e8cd in gdk_x11_gc_values_to_xvalues ()
   from /opt/gnome/lib/libgdk-x11-2.0.so.0
#1  0x4033f5d0 in _gdk_x11_gc_new () from /opt/gnome/lib/libgdk-x11-2.0.so.0
#2  0x40315bf1 in gdk_gc_new_with_values ()
   from /opt/gnome/lib/libgdk-x11-2.0.so.0
#3  0x4031c23e in gdk_pixmap_create_gc ()
   from /opt/gnome/lib/libgdk-x11-2.0.so.0
#4  0x40315bf1 in gdk_gc_new_with_values ()
   from /opt/gnome/lib/libgdk-x11-2.0.so.0
#5  0x403268d3 in gdk_window_get_bg_gc ()
   from /opt/gnome/lib/libgdk-x11-2.0.so.0
#6  0xbfffd65c in ?? ()
#7  0x00000030 in ?? ()
#8  0x403127ac in gdk_drawable_set_colormap ()
   from /opt/gnome/lib/libgdk-x11-2.0.so.0
Previous frame inner to this frame (corrupt stack?)

Comment 3

13 years ago
can you get line number symbols for libdk-x11-2.0.so.0?
(Reporter)

Comment 4

13 years ago
(In reply to comment #3)
> can you get line number symbols for libdk-x11-2.0.so.0?

how'd I do that?

Comment 5

13 years ago
erm, i should have used copy+paste, i meant: /opt/gnome/lib/libgdk-x11-2.0.so.0

you'll have to look in your gnome vendor's support site to see how to do it. 
(ie browse suse)
-> no reply 

Also, since the installer is no longer included in Linux Firefox Builds/Releases i close this report as invalid. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
Version: unspecified → 1.0 Branch
You need to log in before you can comment on or make changes to this bug.