In the "Find a Specific Bug" the status field is misleading

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
14 years ago
13 years ago

People

(Reporter: emmanuel, Assigned: emmanuel)

Tracking

Details

Attachments

(1 attachment)

(Assignee)

Description

14 years ago
One of my users complained today that the name of 'status' field is misleading.
Doing searchs for 'closed' bugs gets you bugs that are have the statuses
RESOLVED and VERIFIED although the user expected only bugs that have the CLOSED
status.

Investigating, this search uses globals.pl's IsOpenedState() function which
defines the open status as bugs that are NEW, REOPENED, ASSIGNED and UNCONFIRMED
(all other bugs being in the closed status).

I have to agree with him that closed and CLOSED not being the same thing is a
bit confusing. Recommand calling the field State, instead.
(Assignee)

Comment 1

14 years ago
Created attachment 196172 [details] [diff] [review]
One-liner that changes 'Status' to 'State'
Assignee: myk → eseyman
Status: NEW → ASSIGNED
Attachment #196172 - Flags: review?(myk)
Comment on attachment 196172 [details] [diff] [review]
One-liner that changes 'Status' to 'State'

Calling the field "Status" is appropriate, because that's what you're searching, even if your only options are to search for combinations of statuses rather than individual statuses.

I see how the "CLOSED" status could be confused with the set of statuses that all indicate a bug is "Closed", but if we changed the name of this field to "State" we'd have to deal with the corollary confusion of folks wanting to understand the relationship between "State" and "Status".

A better approach would be to make that relationship clear somehow for folks who are interested in probing deeper, perhaps via tooltips on the menu items.
Attachment #196172 - Flags: review?(myk) → review-
(Assignee)

Comment 3

13 years ago
(In reply to comment #2)
> 
> I see how the "CLOSED" status could be confused with the set of statuses that
> all indicate a bug is "Closed", but if we changed the name of this field to
> "State" we'd have to deal with the corollary confusion of folks wanting to
> understand the relationship between "State" and "Status".

Don't we already deal with this?
We regularly get mails on the mozilla-webtools and bugzilla-devel mailing lists from people wanting to know why bugs that have RESOLVED/VERIFIED are strike-through-ed, leading us to explain that bugs that have a RESOLVED/VERIFIED/CLOSED status are in a closed state.

> A better approach would be to make that relationship clear somehow for folks
> who are interested in probing deeper, perhaps via tooltips on the menu items.

Translating the Bugzilla templates, I came across this text in pages/fields.html.tmpl :

          No resolution yet. All [% terms.bugs %] which are in one of
          these "open" states have the resolution set to blank. All

which is sufficient for me.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.