Incorrectly displaying RSS item title which is in UTF-8

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
13 years ago
10 years ago

People

(Reporter: cstef, Assigned: mscott)

Tracking

1.7 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

I added RSS feed at http://www.artlebedev.ru/kovodstvo/kovodstvo.rdf. It is in
UTF-8.
The content of <title> tag for individual items is shown incorrectly (subject
field in right pane) - some latin characters, while the header is quite correct
phrase in Russian, and it is correctly displayed if I open the same URL in FireFox.
The channel name in the left pane of mail window is displayed correctly, and so
does the Sender field of the right pane.

Reproducible: Always

Steps to Reproduce:
1. Subscribe to feed http://www.artlebedev.ru/kovodstvo/kovodstvo.rdf
2. Position the cursor on that feed
Actual Results:  
Some latin characters are shown in the subject filed of right pane.

Expected Results:  
Russian characters should be seen instead.

I tried to delete the subscription and then re-add it, but the result is the same.

Comment 1

13 years ago
This feed displays correctly for me with TB 1.5b1-0904.  There have been 
numerous fixes to TB's RSS handling since the 1.0 was branched off; please don't 
file any additional bugs, especially about RSS, until you've tested with at 
least a 1.5 build, if not a trunk (1.6) build.
Version: unspecified → 1.0
Yep, WFM.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050916 Thunderbird/1.4
ID:2005091605
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

13 years ago
I (the reporter of the bug) tried this feed on Thuderbird 1.5 and it seems to work correctly.

Updated

13 years ago
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
Version: 1.0 → 1.7 Branch
You need to log in before you can comment on or make changes to this bug.