tabs won't close, program won't exit

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
major
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Michael Vanier, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20050916 SeaMonkey/1.1a
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20050916 SeaMonkey/1.1a

On a fresh CVS compile and install of the Seamonkey suite (configured with
suite,calendar,xulrunner), once started, the program will not exit either by
hitting control-Q or selecting File/Exit.  In addition, tabs, once created, do
not close.  However, newly-created windows do close correctly.

Reproducible: Always

Steps to Reproduce:
1. Launch seamonkey.
2. [optional] Create a tab.
3. Try to close it.
4. Try to exit the program.
Actual Results:  
If there are multiple tabs open, the usual dialog box comes up asking if you
want to close all tabs.  Selecting "close all tabs" does nothing.  Trying to
close the tabs manually by selecting File/Close or hitting the tab close button
in the upper right corner also does nothing.  The tabs stay open for the
duration of the program, and the program has to be manually killed to get it to
exit.

Expected Results:  
The tabs should close on demand and the program should exit when requested.

This is using the classic theme and a new user profile.

Comment 1

13 years ago
What JS console messages do you get? This could be the same problem in bug 308788.
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> What JS console messages do you get? This could be the same problem in bug 308788.

Here's the message when I try to close a tab:

Error: uncaught exception: [Exception... "Failure arg 0
[nsIDocShell.contentViewer]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)" 
location: "JS frame :: chrome://global/content/bindings/tabbrowser.xml ::
removeTab :: line 957"  data: no]

And here's the message when I try to quit the program:

Error: uncaught exception: [Exception... "Failure arg 0
[nsIDocShell.contentViewer]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)" 
location: "JS frame :: chrome://navigator/content/navigator.js ::
WindowIsClosing :: line 2561"  data: no]
(Reporter)

Comment 3

13 years ago
(In reply to comment #2)
> (In reply to comment #1)
> > What JS console messages do you get? This could be the same problem in bug
308788.
> 
> Here's the message when I try to close a tab:
> 
> Error: uncaught exception: [Exception... "Failure arg 0
> [nsIDocShell.contentViewer]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)" 
> location: "JS frame :: chrome://global/content/bindings/tabbrowser.xml ::
> removeTab :: line 957"  data: no]
> 
> And here's the message when I try to quit the program:
> 
> Error: uncaught exception: [Exception... "Failure arg 0
> [nsIDocShell.contentViewer]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)" 
> location: "JS frame :: chrome://navigator/content/navigator.js ::
> WindowIsClosing :: line 2561"  data: no]

BTW I just did a CVS update and recompiled, and the problem is no longer there.


Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 4

13 years ago
No specific bug / patch referenced as the fix.

-> WORKSFORME
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.