Cursor navigation ignores (custom) keyboard mappings on Mac OS X

RESOLVED DUPLICATE of bug 282097

Status

()

RESOLVED DUPLICATE of bug 282097
13 years ago
12 years ago

People

(Reporter: danny.bloemendaal, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

OSx allows you to create your own keyboard mappings by placing a file
DefaultKeyBinding.dict in ~/Library/KeyBindinges. This is very convenient
because it allows you to 'program' for instance the home and end keys in a
usuable way (like going to the start or end of a line).
Fortunately, most osx apps respond to this. Obviously, the system generates the
proper keyboard events (e.g. move to end of line) and the app can deal with it.

Not Firefox, which makes it suck big time for text editing using stuff like
Midas/wysiwyg editing.
In 1.0.6, nothing happened when I pressed my End key. Ok, that's bad to begin
with, but in 1.5 it makes me jump to the end of the page (way beyond the field
that I'm typing in).

To summarize: Firefox should listen to what the os is telling him and treat
keyboard signals like it should. 

Reproducible: Always




To have caret navigation that is like it is on Windows, create a text file:
~/Library/KeyBindings/DefaultKeyBinding.dict
With this content:
======================================================================
/* ~/Library/KeyBindings/DefaultKeyBinding.dict */
{
    
    "\UF72B" = "moveToEndOfLine:";  /* End */
    "$\UF72B" = "moveToEndOfLineAndModifySelection:";  /* Shift-End */
    "\UF729" = "moveToBeginningOfLine:";  /* Home */
    "$\UF729" = "moveToBeginningOfLineAndModifySelection:";  /* Shift-Home */
    "\UF72C" = "pageUp:"; /* Page-up */
    "\UF72D" = "pageDown:"; /* Page-down */
    "^\UF729" = "moveToBeginningOfDocument:"; /* ctrl home */
    "$^\UF729" = "moveToBeginningOfDocumentAndModifySelection:"; /* shift-ctrl
home */
    "^\UF72B" = "moveToEndOfDocument:"; /* ctrl end */
    "$^\UF72B" = "moveToEndOfDocumentAndModifySelection:"; /* shift-ctrl end */
    "^\UF703" = "moveWordForward:"; /* ctrl right */
    "$^\UF703" = "moveWordForwardAndModifySelection:"; /* shift-ctrl right */
    "^\UF702" = "moveWordBackward:"; /* ctrl left */
    "$^\UF702" = "moveWordBackwardAndModifySelection:"; /* shift-ctrl left */
    
    
    
    "^z" = "undo:";  /* ctrl-z */
    "^x" = "cut:";  /* ctrl-x */
    "^c" = "copy:";  /* ctrl-c */
    "^v" = "paste:";  /* ctrl-v */
}
==================================================
See
http://developer.apple.com/documentation/Cocoa/Conceptual/BasicEventHandling/Tasks/TextDefaultsAndBindings.html
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

13 years ago
Summary: Cursor navigation is a real PITA and ignores (custom) keyboard mappings on osx → Cursor navigation ignores (custom) keyboard mappings on Mac OS X

*** This bug has been marked as a duplicate of 282097 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.