Closed Bug 308836 Opened 16 years ago Closed 16 years ago

Background Color Overflows INPUT type=FILE form element, image missing

Categories

(Toolkit :: Form Manager, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 52500

People

(Reporter: umineiro, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

In a input tag of type file, when you set the css property of background, the
color floods off the frame of the input element.

Reproducible: Always

Steps to Reproduce:
1.Just save the sample code in the aditional information to a file and open it
to observe the bad behaviour
2.Optionally see it in the bug test page I´ve set up in the lURL above.

Actual Results:  
In a input tag of type file, when you set the css property of background, the
color floods off the frame of the input element all the way up to the width
specified.

Expected Results:  
The background should fill only the interior of the input tag frame.

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="pt-br" lang="pt-br">
<head>
  <title>Bug Test</title>
</head>
<body>
  <form id="form" enctype="multipart/form-data" method="post" action="javascript;">
    <label for="anexo">Anexo</label>
    <input type="file" id="anexo" size="25" style="background: #fffce2
url(warning_obj.gif) no-repeat center left; width:30em;" />
  </form>
</body>
</html>

*** This bug has been marked as a duplicate of 52500 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.