Preferences/Connection Settings... does nothing

RESOLVED WORKSFORME

Status

()

Firefox
Preferences
--
major
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: Adam Jackson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

Clicking on the Connection Settings button does nothing with the 1.5 beta.  As
in, you click on it, and the button is highlighted while the mouse button is
down, but no dialog comes up.

Works fine in 1.0.6.  Using Mac OS X 10.3.9.

Reproducible: Always

Steps to Reproduce:
1. Open the preferences dialog.
2. Select the General pane.
3. Click on the "Connection Settings..."

Actual Results:  
No Connection Settings dialog.

Expected Results:  
Shown me the Connection Settings dialog.

Using default theme.
(Reporter)

Comment 1

12 years ago
the Javascript Console shows me this message when triggering the bug:

Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIDOMJSWindow.openDialog]"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://global/content/bindings/preferences.xml :: openSubDialog :: line 803" 
data: no]
(Reporter)

Comment 2

12 years ago
worksforme in 1.5b2.  this seems to be a symptom of a larger issue where
javascript just loses its mind after a time and various things will just stop
working (buttons on web pages, etc), but that's not the same bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.