focus for "two-finger" scrolling on mac does not follow to frontmost tab using key shortcuts

RESOLVED FIXED

Status

()

Firefox
Tabbed Browser
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: xolaware.llc, Assigned: Mark Mentovai)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

with two separate pages open for scrolling, if i use the mac key shortcuts to
get from one tab to the second (or vice versa), then use the two-finger
scrolling method available on my iBook G4 or my powerbook G4 aluminium, it does
not scroll the frontmost page, and in fact scrolls the page i was previously on.

if i click in the tab i want, the problem does not manifest.

if after using a key shortcut, i then click within the window for two finger
scrolling, the problem does not manifest

(but of course, both of these defeat the purpose and acceleration offered by not
having to move the mouse to a tab or having to click focus in a page to cause it
to scroll.)

Reproducible: Always

Steps to Reproduce:
1. open the same or separate URLs that require scrolling in two separate tabs
2. make the focus be in the first tab, and note the position of the scrollbar
3. use Cmd-2 to get to the second tab
4. attempt to 2-finger scroll in that tab

Actual Results:  
a] in the frontmost tab, nothing happens
b] if you go back to the tab previously being visited, notice that the scroll
   position has changed

Expected Results:  
a] the frontmost tab should scroll
b] the previously visited tab should remain where it was

i will be glad to beta test patches, as i know that there are not that many
platforms on which to test this problem, yet.

Comment 1

12 years ago
Related to bug 282256?
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> Related to bug 282256?

indeed, i just tried that bug, and as the behavior described seems very similar
in terms of look'n'feel, perhaps one proper fix under the hood will fix both bugs.

(and to go with that behavior, Cmd-` to switch amongst windows seems to also
cause similar problems; i went looking for such a bug & couldn't find one for
that behavior.)

i'm not going to mark it as a duplicate just yet, but rather put a note in the
other bug-report that this one is related so that if an attempt is made to fix
it, it will be done at an appropriate level in the code.
(Assignee)

Comment 3

12 years ago
This may be a dupe.  I've known about it for a long time.

It's not strictly a dupe of bug 282256.  It's not a dupe of bug 255415, but I
have a solution in that one.  The symptoms described in all three bugs share the
same cause and solution.

If someone else wants to hunt down the actual dupe, go ahead.
Assignee: nobody → mark
Status: UNCONFIRMED → NEW
Depends on: 255415
Ever confirmed: true
(Assignee)

Comment 4

12 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.