Misspelled words break scrolling

RESOLVED DUPLICATE of bug 337871

Status

()

RESOLVED DUPLICATE of bug 337871
13 years ago
13 years ago

People

(Reporter: mozilla, Assigned: mscott)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
20050914 trunk

NOTE: Please bear with me as this bug is strange, but highly aggravating.

STEP TO REPRODUCE:

1. Instead of trying to explain what exactly has to happen, just copy the
   following text and paste it into a composition window (after wrestling with 
   bug 308427):

-----TEXT TO COPY-----
This line does not contain a misspelling.
Nor does this line.
We need a few lines without a misspelling, so here's another.
Ok. Now I will spel something incorrectly.

"That's fine," you think to yourself. "What's
wrong with this guy?"

Now, we still need a few more lines. Whether these
have misspellings is not critical. But, we are going
to need a misspelling soon.

We still need a few lines.

This has to be long to make sure that the misspelling aren't on the screen at
the same time.

Let's put a misspeliing.

This is some text to go below the line above.
We need a few lines down here too.
This should do it.
-----TEXT TO COPY-----

2. Place your cursor after the period at the end of the line that reads, "Let's 
   put a misspeliing."

3. Now try to scroll down using the arrow button at the bottom of the scrollbar, 
   or clicking in the empty gutter below the scroll thumb.

RESULT:
You can't.

For even more fun, try scrolling up and placing your cursor somewhere else in
the message. Watch the message jump when you click.
(Reporter)

Comment 1

13 years ago
After step 2, scroll to the top of the message before attempting step 3.
Yep, linux, branch too.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050916 Thunderbird/1.4
ID:2005091605

I'm able to get to the bottom of the page by dragging the scrollbar
"scroller"(?) though.
OS: Windows XP → All

Comment 3

13 years ago
Also reproducible with SeaMonkey 1.0a.

Comment 4

13 years ago
Using Thunderbird release 1.5 (20051201) on Windows XP (SP2), a misspelt word in a message in the Compose window causes the scrollbar position (and hence the field of view) to jump when the text cursor is moved through the word.

In other words, in a message long enough to require a vertical scrollbar, there is a misspelt word.  It is underlined with red dots.  When I run the text cursor through the message, using the cursor keys, the vertical scroll position of the window jumps wildly as the text cursor passes through and leaves the misspelt word.  

This is in addition to the jump that is reported here when clicking in a misspelt word.  

I am using Rich Text (HTML) mails, with different paragraphs in different styles, but I am not sure if this is relevant or not.

Hope this helps!
Alastair

Comment 5

13 years ago
*** Bug 339076 has been marked as a duplicate of this bug. ***

Comment 6

13 years ago
Updating Product/Components to reflect the fact that this is a global issue (not only a thunderbird one), will attach testcase.
Assignee: mscott → nobody
Component: Message Compose Window → Keyboard: Navigation
Product: Thunderbird → Core
QA Contact: keyboard.navigation
Summary: Misspelled words make scrolling impossible → Misspelled words breaks keyboard scrolling

Comment 7

13 years ago
Created attachment 223164 [details]
testcase

testcase from bug 339076's reporter (slightly modified)

Updated

13 years ago
Keywords: testcase

Updated

13 years ago
Summary: Misspelled words breaks keyboard scrolling → Misspelled words break keyboard scrolling
(Reporter)

Comment 8

13 years ago
This doesn't just affect keyboard scrolling. Mouse scrolling is also affected.
Summary: Misspelled words break keyboard scrolling → Misspelled words break scrolling
(Reporter)

Comment 9

13 years ago
This definitely shouldn't live under the keyboard navigation component, but I'm not sure where it should go other than XP/Misc.

Comment 10

13 years ago
(In reply to comment #8)
> This doesn't just affect keyboard scrolling. Mouse scrolling is also affected.
You are right, on Thunderbird, I get some "scroll jump" when scrolling in the compose window using scrollbars arrow. 

 -> Core/Spelling Checker (more suitable IMHO, but not 100% sure)
Assignee: nobody → mscott
Component: Keyboard: Navigation → Spelling checker
QA Contact: keyboard.navigation → spelling-checker

Comment 11

13 years ago
(In reply to comment #8)
> This doesn't just affect keyboard scrolling. Mouse scrolling is also affected.

Scrolling with scrollbar, middlemouse ("autoscroll") and mousewheel WFM

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a2) Gecko/20060522 BonEcho/2.0a2 - Build ID: 2006052204

and 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060517 Minefield/3.0a1 - Build ID: 2006051706

Comment 12

13 years ago
I'm pretty sure that this is the same as bug 337871 (which already has a patch, so I'm duping against it). The problem is that it would try to scroll the spell suggestions into view at various times.

*** This bug has been marked as a duplicate of 227871 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 13

13 years ago
(In reply to comment #12)
> I'm pretty sure that this is the same as bug 337871 
[...]
> *** This bug has been marked as a duplicate of 227871 ***
                                                ^^^^
I think you may have made a typo :)
(Reporter)

Updated

13 years ago
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 14

13 years ago

*** This bug has been marked as a duplicate of 337871 ***
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.