<ol> hyperlink reflow on click causes text to move off screen without providing scroll bar

RESOLVED DUPLICATE of bug 105894

Status

()

--
minor
RESOLVED DUPLICATE of bug 105894
13 years ago
13 years ago

People

(Reporter: brewthatistrue, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050913 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050913 Firefox/1.6a1

When you click the link, all text moves to the left, some of it moving offscreen.

Unfortunately, even though the content scrolled, there bar to scroll back to the
left.

A workaround is to highlight the text and drag to the left.

Reproducible: Always

Steps to Reproduce:
1. Click link (open in new background tab to prevent refresh)
Actual Results:  
Text flows off screen, and no scroll bar is provided.

Expected Results:  
Text should not flow off screen.
In the even that text ever does flow off screen (which it shouldn't), scroll
bars should be presented.
(Reporter)

Comment 1

13 years ago
Created attachment 196401 [details]
testcase
(Reporter)

Comment 2

13 years ago
Created attachment 196402 [details]
reduced testcase
(Reporter)

Updated

13 years ago
Summary: reflow on hyperlink click causes text to move off screen without providing scroll bar → <ol> hyperlink reflow on click causes text to move off screen without providing scroll bar

Comment 3

13 years ago
Created attachment 196447 [details]
testcase for DOM Inspector

The reduced testcase is a minimal testcase, as it should be.
I added a <hr> for seeing what is going on.
<body> has a margin of 8px
<ol> has a padding of 40px
<a> starts at	      48px
<hr> starts at 8px because of <body> margin, and has a width of 40px, so ends
right at the position where <a> starts
When you click on the link <a>, it gets redrawn starting at 8px, so I assume
the padding of 40px is lost temporarily. After some a very short time, the link
gets redrawn again, moving to its correct position starting at 48px.
Attachment #196401 - Attachment is obsolete: true

Comment 4

13 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20050916 SeaMonkey/1.1a

When you click the link in the testcase, the padding is lost, and the link
reloads the file from the server. When this is done, the file is drawn again, so
the padding is restored.
Keywords: testcase

Comment 5

13 years ago
Bug 105894 Clicking a partially off-screen link shouldn't scroll the page

*** This bug has been marked as a duplicate of 105894 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.