Send .ics files as text/calendar (Cannot subscribe to holidays calendars)

RESOLVED FIXED

Status

mozilla.org Graveyard
Server Operations
--
minor
RESOLVED FIXED
13 years ago
3 years ago

People

(Reporter: Luca Capello, Assigned: justdave)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050911 Firefox/1.0.6 (Debian package 1.0.6-5)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050911 Firefox/1.0.6 (Debian package 1.0.6-5)

From the holidays calendar instruction:
=====
We've got some calendar holiday files available for download. To add these to
your calendar, install the Calendar and click on the links below. You will be
prompted to subscribe to them. That way you don't have to continually download them.
=====

Clicking on the links doesn't work nor in Calendar/Firefox-1.0.6 neither in
Calendar/Mozilla-1.7.11 (both as Debian packages), because the link are in the
http:// form, not in the webcal:// form. If I manually open the link as
webcal://[link], I can subscribe.

Reproducible: Always

Steps to Reproduce:
1. Install the calendar extension
2. Open http://www.mozilla.org/projects/calendar/caldata/EnglishHolidays.ics

Actual Results:  
The calendar is open as a plain text page in the browser.

Expected Results:  
The calendar extension should ask to subscribe to the calendar.

I tested only on GNU/Linux, but I'm 100% sure that the problem is present in all
platforms/OSes.

Comment 1

13 years ago
I don't know much about calendars, but I'm going to bet that in fact the reason
is because it's sent as text/plain.

According to this non-normative but quite informative page I found
(http://www.innerjoin.org/iCalendar/calendar-mime-type.html), the correct mime
type is text/calendar, and webcal:// is a hack for if you can't set mime types
on your server.

So really this bug should be to add calendars to the list of known mime types on
the mozilla servers.

Confirming, changing summary.
Severity: major → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Cannot subscribe to holidays calendars as the link is not in the webcal:// form → Send .ics files as text/calendar (Cannot subscribe to holidays calendars)
(Reporter)

Comment 2

13 years ago
> According to this non-normative but quite informative page I found
> (http://www.innerjoin.org/iCalendar/calendar-mime-type.html), the correct
> mime type is text/calendar, and webcal:// is a hack for if you can't set
> mime types on your server.

text/calendar is the mime type set in the RFC for iCal
(http://www.ietf.org/rfc/rfc2445.txt, section 3.1).

> So really this bug should be to add calendars to the list of known mime
> types on the mozilla servers.

So, this is the right way: I tried on my server (online, not local) and as soon
as I add the mime type to Apache2, I don't need anymore the webcal:// handler
(available for test at http://luca.pca.it/stuff/EnglishHolidays.ics).

IE-6 doesn't know how to proceed with webcal:// , while it asks to save the file
if the web server streams text/calendar mime type.

FYI, however, it seems that the *unofficial* webcal:// protocol is the most
used: http://en.wikipedia.org/wiki/Webcal or http://icalshare.com/faq.php . The
Apple website and the NASA one still use the webcal:// handler.
(Reporter)

Comment 3

13 years ago
[OT] Sorry for the noise about add/remove me in the cc:, I wrongly set the
general bug preferences.
-> server-ops, where it should have been (if this is even still relevant).
Assignee: mozilla.webmaster → server-ops
Component: webmaster@mozilla.org → Server Operations
QA Contact: danielwang → justin
webcal:// is used to cause a subscription to happen.
http:// is used to download the file and import it as-is into your calendar client (without subscribing to the source).

serving it as http:// with a mime-type of text/calendar should just import the existing file into your calendar program, and not subscribe to the source.

That said, having it as text/calendar should make it launch in your calendar app instead of displaying the file contents in your browser window.
Assignee: server-ops → justdave
Done.  This type has been added to both mozilla.com and mozilla.org.

Verified via wget that the files are now serving as text/calendar
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.