Updates radio button not checked

RESOLVED DUPLICATE of bug 309015

Status

()

RESOLVED DUPLICATE of bug 309015
13 years ago
13 years ago

People

(Reporter: mossop, Assigned: mossop)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Assignee)

Description

13 years ago
When the user has chosen "Ask me what to do", that radio button isnt checked
when the options window is opened
(Assignee)

Updated

13 years ago
Assignee: nobody → mossop
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

13 years ago
Created attachment 196437 [details] [diff] [review]
Patch to always set selection radio button

Since bug 303988, an element update only happens if the element doesn't already
have the value you're trying to change it to. An unintialised radiogroup has no
value. Unfortunatly since the pref for this radiogroup is boolean, that blank
is assumed to mean false. So when initialising with a false preference value,
the radiogroup is determined to be not needing an update.

This patch just makes sure that radiogroups are always initialised. Presumably
since that is ok for checkboxes then it is ok for radiogroups.
Attachment #196437 - Flags: review?(mconnor)
(Assignee)

Updated

13 years ago
Flags: blocking1.8b5?

Updated

13 years ago
Attachment #196437 - Flags: review?(mconnor) → review+
(Assignee)

Comment 2

13 years ago
Fixed on trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Assignee)

Updated

13 years ago
Attachment #196437 - Flags: approval1.8b5?

Updated

13 years ago
Attachment #196437 - Flags: approval1.8b5? → approval1.8b5+

Updated

13 years ago
Flags: blocking1.8b5? → blocking1.8b5+
Comment on attachment 196437 [details] [diff] [review]
Patch to always set selection radio button

I'm going to back this out in bug 309015.
Attachment #196437 - Attachment is obsolete: true
Attachment #196437 - Flags: review+
Attachment #196437 - Flags: approval1.8b5+
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

*** This bug has been marked as a duplicate of 309015 ***
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.