Shared extensions/themes strings should be separated for l10n to manage gender of substantives

VERIFIED FIXED in mozilla2.0

Status

()

VERIFIED FIXED
13 years ago
7 years ago

People

(Reporter: mdalco, Unassigned)

Tracking

2.0 Branch
mozilla2.0
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050715 Firefox/1.0.6 SUSE/1.0.6-4.3
Build Identifier: ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla1.8-l10n/firefox-1.4.it.linux-i686.tar.gz

Extensions and Themes strings shares some l10n text between themes and
extensions, but in Italian (and I think also in other languages) they are
respectively female and male... 

For example the string creator.label ("Created By:", in
toolkit/mozapps/extensions/about.dtd) in Italian should be translated in "Creata
da:" when referred to an extension and "Creato da:" when referred to a theme.

I found these strings that should be splitted for Themes and Extensions:

- in toolkit/mozapps/extensions.properties:
      dssSwitchAfterRestart
      incompatibleMessageNoApp
      incompatibleMsg
      incompatibleMsgSingleAppVersion
      incompatiblePlatformMessage
      invalidFileExtMessage
      invalidGUIDMessage
      restartBeforeUninstallMessage
      restartBeforeInstallMessage

- in toolkit/mozapps/about.dtd
      creator.label


Reproducible: Always

Steps to Reproduce:

Comment 1

13 years ago
Confirming, this looks like one of those problems that can easily create
problems.

This could be easily fixed for DTDs, as those can use entities themselves, so we
could have one string for languages where grammar doesn't make a difference,
and two separate ones where it does. (And have a unused shared entitity.)
Sadly, this doesn't work for properties. Seems like we need to fork those
strings.

One cumbersome way to work around this for 1.5 may be to use wordings like
extensioncomponent and themecomponent. That is really unsweet, but I'd have to
see a list of affected locales *soon* to push this for 1.5.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

13 years ago
>This could be easily fixed for DTDs, as those can use entities themselves, so we
>could have one string for languages where grammar doesn't make a difference,
>and two separate ones where it does.

IMHO, this is a bad idea because we will end having three strings, instead of
only two.

My suggestion would be the following:

If now we have an entity like this:

<!ENTITY  creator.label "Created By:">

Split it into two:

<!ENTITY  theme_creator.label "Created By:">
<!ENTITY  extension_creator.label "Created By:">

In English they will have the same string but in other languages we could use
different ones (this is useful also for my 'es-ES' l10n team).
How could the following apply to this bug?
dssSwitchAfterRestart=Restart %S to use.
which for Firefox is
Restart Firefox to use.

We will hopefully simplify the error text for 2.0 in bug 302527

Comment 4

13 years ago
Well, that %s could be Firefox or Thunderbird, which have different genders in
some languages. Not precisely the same problem, and this is usually worked around
by saying something like
Restart program %S to use.
I have seen Ben preferring the use of the term addon for extensions and
themes... I'm wondering if a similar approach couldn't be taken here like:
incompatibleMessageNoApp=%S %S could not be installed because it is not
compatible with %S.

Addon MyThemeName 1.8 could not be installed because it is not compatible with
Firefox.
(Reporter)

Comment 6

13 years ago
(In reply to comment #3)
> How could the following apply to this bug?
> dssSwitchAfterRestart=Restart %S to use.
> which for Firefox is
> Restart Firefox to use.

But the verb "to use" is referred to the extension or to the theme. In Italian
this sentence should be translated in:
Riavvia Firefox per utilizzarla - related to extensions,
Riavvia Firefox per utilizzarlo - related to themes.
The ui for extensions and themes will most likely be re-written for 2.0
http://wiki.mozilla.org/Firefox:Extension_Manager_UI

If it is it would be simpler to generalize so the code doesn't have to special
case for ui strings each type of addon that can be installed... similar to what
is done for the app names.
> But the verb "to use" is referred to the extension or to the theme. In Italian
> this sentence should be translated in:
> Riavvia Firefox per utilizzarla - related to extensions,
> Riavvia Firefox per utilizzarlo - related to themes.

In Czech l10n we solved this by using "Addon %s" everywhere where %s can refer
to extension or theme. The same holds for the aplication name where we use
Aplication &brandName;  
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
Dave and Blair, how does the new Add-ons Manager handle the issues mentioned on this bug? A lot of strings have been changed with the rewrite but I wonder if there are still open cases where we do not obey the gender.
I could be wrong but I don't remember having this kind of problems localizing the new Add-on manager (most strings use the term "add-on" explicitly).
(In reply to comment #9)
> Dave and Blair, how does the new Add-ons Manager handle the issues mentioned on
> this bug? A lot of strings have been changed with the rewrite but I wonder if
> there are still open cases where we do not obey the gender.

Well, there's still no way to localize based on gender, especially given the new support for arbitrary addon types (we're no longer restricted to just extensions and themes). But comment 8 and comment 10 suggest it's no longer a problem thanks to generic wording.
Er, and by "generic wording", I mean gender-neutral wording.
Basically all of the strings should be referring to add-ons now, aside from the category names so I'd be inclined to call this fixed by the new EM UI (bug 554007). Please reopen if there are still problems though.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Sounds fair. Marking as verified fixed.
Status: RESOLVED → VERIFIED
Depends on: 554007
Target Milestone: --- → mozilla2.0
Version: unspecified → 2.0 Branch
You need to log in before you can comment on or make changes to this bug.