Firefox shows that it remembers to save a filetype, but still asks you about it

RESOLVED DUPLICATE of bug 236541

Status

()

RESOLVED DUPLICATE of bug 236541
13 years ago
10 years ago

People

(Reporter: dave1g, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

the download section of this website http://www.welcometotehscene.com/ when a
torrent link is clicked on instead of downloading it in the background, firefox
bugs me about it, even though it shows the check box already checked for
downloading automatically.

This appears to only happen when a link to a file is is actually a link to a
script that then provides the file.

Reproducible: Always

Steps to Reproduce:
1. set .torrent files to be downloaded automatically
2. go to the website listed and click a torrent link
http://tehscene.pjeer.com/download.shtml
3. 

Actual Results:  
firefox will still prompt you for what to do.

Expected Results:  
should have downloaded in the background silently
(Reporter)

Comment 1

13 years ago
Created attachment 196495 [details]
Screenshot of problem

just showing what I mean wiht a screenshot

Comment 2

13 years ago
This happens because the site uses Content-Disposition: attachment.  (I saw this
when I copied URL from download manager and used wget -S.)

I have to agree that Firefox's UI in this case is a bit wonky.  For one, a
content-disposition of attachment probably shouldn't override the user's
"always..." choice if the user's choice was "Save".

*** This bug has been marked as a duplicate of 236541 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.