Junk mail filter marks messages as junk even if placed in a seperate folder manually or by filter

RESOLVED DUPLICATE of bug 198961

Status

Thunderbird
General
--
major
RESOLVED DUPLICATE of bug 198961
12 years ago
11 years ago

People

(Reporter: Aaron H, Assigned: Scott MacGregor)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: 1.5 Beta 1 (20050908)

Junk mail filter marks messages as junk even if placed in a seperate folder 
manually or by filter. The only option as of this writing is to put every 
email address I don't want scanned into my personal or collected address 
books. This won't work. If I make my own folders and use filters to sort 
incoming email, obviously junkmail should not override my filter. Right now it 
does. There should be a way to limit what folders the junkmail filter is 
allowed to scan. It makes sense.

Reproducible: Always

Steps to Reproduce:
1.Create a unique folder
2.Create a filter to move incoming messages to your unique folder
Actual Results:  
Observe as Junkmail adaptive filter will intermittently move already archived 
emails from unique folders to the Junk folder (solely becuase its not in the 
personal or collected address books)


Expected Results:  
Junkmail controls should allow individual settings for inclusion or exclusion 
by a folder basis so one does not have to add every email address to a 
personal or collected address book just to prevent the adaptive filter from 
moving already catagorized emails.

I would also like to mention that Junkmail controls should aslo allow you to 
exclude emails from filtering based on multiple address books, rather then one 
or the other (which is the way it is now for example, exclude filter by 
personal address book OR collected address book, but you can't exclude filter 
by both).
(Reporter)

Updated

12 years ago
Version: unspecified → 1.5

Comment 1

12 years ago
(In reply to comment #0)
> Junk mail filter marks messages as junk even if placed in a seperate folder 
> manually or by filter. <..>

Related to/duplicate of bug 302324, Core bug 198961 and/or Core bug 211826?
 
> Junkmail controls should allow individual settings for inclusion or exclusion 
> by a folder basis <..>

Duplicate of bug 262625 -> Core bug 189970?
 
> I would also like to mention that Junkmail controls should aslo allow you to 
> exclude emails from filtering based on multiple address books <..> 

Duplicate of Core bug 187771?

Comment 2

12 years ago
I haven an IMAP account with multiple folders in which I collected various mail 
over a longer period. Recently I added Thunderbird to my clients and wanted to 
try the spam filter. I trained it with some 100 ham and spam emails (yes, I 
collect spam), enabled the adaptive filter and decided to "Move incoming 
messages determined to be junk mail to junk folder". The word "incoming" made 
me believe that this affected only the "inbox" folder, however it actually 
affected all my folders. I don't like this, because these archives contain 
messages, which I decided already upon. The only thing TB could do about them 
is to generate false positives, which I might overlook among numerous real junk 
messages from the inbox.

I agree with Aron's request. At least there should be a distinction between the 
inbox (unchecked mails) and the folders (mails already decided upon).

Workaround: Add a header line "X-Keywords:" to all messages in all folders 
might convince TB to believe it had scanned the email already and prevent it 
from classifying it as junk.

Comment 3

12 years ago
I was just about to file a new bug on behalf of Christian when he found this
one. Here is the UI I was going to suggest:

Since other user might have filters to move e-mails to other IMAP folders, and
want those e-mails to be checked for junk, this new feature should be a
configurable (but unobtrusive) option.

The UI could be similar to the "Subscribe" UI for IMAP and newsgroup accounts.
The following suggestion would add only one button ("Folders") to the current UI:

+--- Junk Mail Controls ---------------------------------------+
|                                                              |
| Thunderbird has several ways to ...                          |
|                                                              |
| Configure Junk Settings for: [ <Account-Name> ] [Folders...] |
|                                                              |
~                                                              ~
+--------------------------------------------------------------+

Klicking on "Folders" yields:

+-- Custom Folder Settings ------------------------------------+
|                                                              |
| Custom Folder Settings for: [ <Account-Name> ] [Folders...]  |
|                                                              |
| Select the folders that Thunderbird should check             |
| incoming messages for Junk mail:                             |
|+------------------------------------------------------------+|
|| Inbox                  [x]                                 ||
|| Drafts                 [ ]                                 ||
|| Sent                   [ ]                                 ||
|| Templates              [ ]                                 ||
|| Trash                  [ ]                                 ||
|| Personal               [x]                                 ||
|| Computers              [x]                                 ||
|| Ham Box                [ ]                                 ||
|+------------------------------------------------------------+|
| Select:  [All]  [None]   [Subscribed]                        |
|                                                              |
|                                        [[ OK ]]  [ Cancel ]  |
+--------------------------------------------------------------+

The account initially shown after "Custom Folder Settings for:" should the the
one that was displayed in the previous dialog. This enables the user to
customize the folders for all accounts in one go, without requiring them to go
back and forth between the two dialogs, and without having to thouch this
setting ("Custom Folder Settings for:") if they only want change the settings
for the account displayed in the previous dialog.

For IMAP accounts, clicking on "Subscribed" selects (only) the folders that are
currently selected under "File / Subscribe". The tooltip for this button should
say "Selects the folders that you have subscribed to."

For POP accounts, the "Subscribed" button would not be visible.

Comment 4

11 years ago

*** This bug has been marked as a duplicate of 198961 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE

Comment 5

11 years ago
Comment 3 is actually better duped to bug 189970.
You need to log in before you can comment on or make changes to this bug.