If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

progress dialog is currently showing undefined progress meter

VERIFIED FIXED

Status

Core Graveyard
Installer: XPInstall Engine
P3
normal
VERIFIED FIXED
18 years ago
2 years ago

People

(Reporter: Cathleen, Assigned: dveditz)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] w/b minus on 03/10 - fix in hand)

(Reporter)

Description

18 years ago
When you doing a XPInstall, our progress dialog during download shows the 
progress dialog as undefined.

This is going to be a problem when users use this beta1 software to upgrade to 
beta 2, because they'll be downloading large xpi files over modem speed.  It 
will look like our browser is locked up or dead, during the download of xpi 
files.
(Reporter)

Comment 1

18 years ago
bad user experience for upgrading to the next release.
nominating for beta1
Keywords: beta1

Comment 2

18 years ago
Have a fix in hand that has been tested on Mac and Windows.  The change is not 
all that much code anyway.
Status: NEW → ASSIGNED
(Reporter)

Updated

18 years ago
Whiteboard: fix in hand

Comment 3

18 years ago
per PDT, need more info. What is hte problem when upgrading to beta2 that we 
have to fix now?
Whiteboard: fix in hand → [NEED INFO] fix in hand
(Reporter)

Comment 4

18 years ago
User's will be encouraged to use their B1 browser to upgrade to B2 bits through 
SmartUpdate site.  Our downloads are fairely large... browser package 4MB, mail 
package 1MB, jre 7MB...  During the download of those large XPI files, it will 
look like browser is dead or locked up, and bad things can happen with no 
idication that the program is still alive.

By getting this fix in, users can see the activity in progress bar and see 
browser working.

Comment 5

18 years ago
Putting on PDT+ radar for beta1.  Get it in ASAP!!  Will turn to minus on 03/10
Whiteboard: [NEED INFO] fix in hand → [PDT+] w/b minus on 03/10 - fix in hand

Comment 6

18 years ago
Fixed.  And I must say, it's quite lovely.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 7

18 years ago
Build 2000-03-10-13-M15(LINUX), 2000-03-10-09-M15(WIN), 2000-03-10-13-M15(MAC)

Looks good on Mac and Windows.  Linux still shows the old progress bar (not so 
lovely I must say ;-)  Reopening.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 8

18 years ago
Strange, it doesn't show the progress activity on unix...
Don is gone on vacation next week.  Dan, can you help?
Assignee: dbragg → dveditz
Status: REOPENED → NEW
(Assignee)

Comment 9

18 years ago
I'm making this fixed. The code change was XP, so if Linux is the one oddball 
there is maybe some other XPFE bug. Created bug 31452 to track the Linux 
problem, which I don't believe is going to be a beta stopper since it's after 
the 3/10 cutoff.
(Reporter)

Comment 10

18 years ago
I agree.  Per Dan's comment, marking this as FIXED.
Please refer to bug 31452 for Linux problem.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 11

18 years ago
Build: 2000-03-14-05-M15-nb1b(LINUX)

Expected progress meter is present.  Marking Verified!
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.